forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: One HTML-/PDF-site for the whole project
Date Wed, 31 Mar 2004 07:55:35 GMT
The site.xml you posted seems fine.  I haven't tried duplicating what 
you did yet.  What are you trying to accomplish?  A whole-project 
html/pdf but with a different file name?

Dave Brondsema

Stephan E. Schlierf wrote:
> A few days ago I posted a question about the static generating of one 
> html-/pdf-file for my whole project (see below).
> Now I lose my way if I shall provide more information to solve this 
> problem ?
> Thank you very much in advancve!
> Stephan
> 
> 
> Stephan E. Schlierf schrieb:
> 
>> Dave Brondsema schrieb:
>>
>>> Stephan E. Schlierf wrote:
>>>
>>>> Hi there,
>>>>
>>>> I'd like to generate one html-/pdf-file for my whole project.
>>>> What I've done until now is:
>>>> - copied aggregate.xmap to project.xmap (in src/core/context)
>>>> - edited sitemap.xmap and inserted a pipeline matching project.xml:
>>>>  <map:match pattern="project.xml">
>>>>     <map:mount uri-prefix="" src="project.xmap" check-reload="yes" />
>>>>  </map:match>
>>>> - rebuilt forrest
>>>> - did a "forrest run".
>>>> Now if I have a lokk at http://localhost:8888/project.html (or 
>>>> project.pdf) everything looks fine and a complete site is generated.
>>>>
>>>> After that I edited the site.xml of my project and added
>>>> <all label="Altogether">
>>>>  <whole_site_html label="Whole Site HTML" href="project.html"/>
>>>>  <whole_site_pdf label="Whole Site PDF" href="project.pdf"/>
>>>> </all>
>>>> Then I did a forrest site to generate a static website but neither the
>>>
>>>
>>>
>>>
>>>> menu entries appears nor the respective files (project.html / 
>>>> project.pdf) are generated.
>>>> What's going wrong ? Can anybody give me a helping hand ?
>>>>
>>>> TIA,
>>>> Stephan
>>>
>>>
>>>
>>>
>>> Well static sites will only generate pages that have links to them.  The
>>>
>>> problem with the missing menu entries is causing the project.html/pdf 
>>> pages not to be generated.
>>>
>>>  From what you say you did for your site.xml it sounds okay.  Can you 
>>> post the entire thing?
>>>
>> If you think of my site.xml - here it comes!
>> TIA,
>> Stephan
>>


-- 
Dave Brondsema : dave@brondsema.net
http://www.splike.com : programming
http://csx.calvin.edu : student org
http://www.brondsema.net : personal

Mime
View raw message