forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: FOP's Forrest-based web site
Date Mon, 23 Feb 2004 20:02:42 GMT

I'm pretty sure you just need to change & to &amp; Since this is an XML
document, & is used for entity references; &amp; will turn into a literal
&

Dave Brondsema

On Mon, 23 Feb 2004, Clay Leeds wrote:

> Uh oh... I got some BUILD FAILED msgs... (I apologize for the long
> msg!).
>
> X [0]                       index.html  BROKEN: The reference to entity
> "bug_status" must end with the ';' delimiter.
> * [0]   0.713s 766b    favicon.ico
> Total time: 0 minutes 28 seconds
>
> BUILD FAILED
> /Users/Shared/_WebDLs/apache-forrest-0.5.1-bin/forrest.build.xml:631:
> Java returned: 1
>
> Total time: 1 minute 16 seconds
> ==============================
>
> I looked in my site.xml file, and the only instances of "bug_status"
> occurred in these lines:
>
> line 66:
> 	    <patch label="Patch Queue"
> href="http://nagoya.apache.org/bugzilla/buglist.cgi?
> bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=&emailtype
> 1=substring&emailassigned_to1=1&email2=&emailtype2=substring&emailreport
> er2=1&bugidtype=include&bug_id=&changedin=&votes=&chfieldfrom=&chfieldto
> =Now&chfieldvalue=&product=Fop&short_desc=%5BPATCH%5D&short_desc_type=al
> lwordssubstr&long_desc=&long_desc_type=allwordssubstr&bug_file_loc=&bug_
> file_loc_type=allwordssubstr&keywords=&keywords_type=anywords&field0-0
> -0=noop&type0-0-0=noop&value0-0
> -0=&namedcmd=Fop+all&newqueryname=fop+patch+queue&tofooter=1&order=Reuse
> +same+sort+as+last+time"/>
>
> Line 77:
> 	    <bugs label="Bugs"
> href="http://nagoya.apache.org/bugzilla/buglist.cgi?
> bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=&emailtype
> 1=substring&emailassigned_to1=1&email2=&emailtype2=substring&emailreport
> er2=1&bugidtype=include&bug_id=&changedin=&votes=&chfieldfrom=&chfieldto
> =Now&chfieldvalue=&product=Fop&short_desc=&short_desc_type=allwordssubst
> r&long_desc=&long_desc_type=allwordssubstr&bug_file_loc=&bug_file_loc_ty
> pe=allwordssubstr&keywords=&keywords_type=anywords&field0-0
> -0=noop&type0-0-0=noop&value0-0-0=&order=bugs.component"/>
> ========
>
> I commented out those lines and the BUILD did not fail (at least not at
> the same place), but what if I need those links? BTW, I notice that
> those links each contain multiple parameters called "bug_status" which
> is strange... I just copied those from the current web page. Perhaps I
> need to grab those values from the actual book.xml file or something...
>
> Any ideas?
>
> After commenting out the above lines, I got a different BUILD FAILED
> error:
>
> BUILD FAILED
> /Users/Shared/_WebDLs/apache-forrest-0.5.1-bin/forrest.build.xml:631:
> Java returned: 1
>
> Total time: 7 minutes 12 seconds
> =====
>
> (no particularly useful info above those line, though!)
>
> I did notice a few BROKEN items, related to problems with altdesign. I
> fixed the problem with altdesign and re-ran forrest, but got another
> BUILD FAILED:
>
> Total time: 9 minutes 46 seconds
>
> BUILD FAILED
> /Users/Shared/_WebDLs/apache-forrest-0.5.1-bin/forrest.build.xml:631:
> Java returned: 1
>
> Total time: 10 minutes 35 seconds
> =====
>
> I do have a problem with the subsection in the development, which has
> links to a tab not under dev/ (check the Development tab on the live
> FOP site to see it in action). Here's the code:
>
>    <development label="Development" href="dev/" tab="development">
> 		<introduction label="Introduction">
> 			<basics label="Basics" href="index.html"/>
> 		</introduction>
>
> 		<design label="Design" href="design/" tab="design">
> 			<basics label="Resolved" href="index.html"/>
> 			<unresolved label="Unresolved (Wiki)"
> href="http://nagoya.apache.org/wiki/apachewiki.cgi?FOPProjectPages"/>
> 			<svg label="SVG" href="svg.html"/>
> 			<fonts label="Fonts" href="fonts.html"/>
> 			<extensions label="Extensions" href="extensions.html"/>
> 		</design>
>
> I don't know how the Design section should be coded in this case.
>
> Web Maestro Clay
>
> p.s. Should I send my site.xml file (or anything else)?
>

-- 
Dave Brondsema
dave@brondsema.net
http://www.brondsema.net - personal
http://www.splike.com - programming
http://csx.calvin.edu - Calvin club

Mime
View raw message