forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: multiple skin descriptors, skin versions
Date Wed, 04 Feb 2004 03:14:30 GMT
Quoting Marshall Roch <marshall@exclupen.com>:

> Dave Brondsema wrote:
> >>IIRC I had added a filename convention too, so a skin would be for
> example:
> >>
> >>  skinname-f0.5-0.3.jar (version 0.3 compatible with forrest 0.5)
> > 
> > I like this.  Simpler is better.
> 
> I thought this was the problem.  Skin version 0.3 might still work for 
> Forrest 0.6 and 0.7, but with your proposed naming scheme, each skin 
> would have to be re-released for each Forrest release, and bug fixes to 
> the skin release for 0.6 would not be applied to the release for Forrest 
> 0.5.
> 

If skin version 0.3 is compatible Forrest 0.5 and still works when 0.6 and 0.7
are released, we could keep skinname-f0.5-0.3.jar  The fetcher could get the
skin with the highest forrest version number possible (less than or equal to the
version of forrest installed, of course).

So the f0.5 would actually mean compatible with forrest 0.5 and greater.  If
compatibility breaks at 0.8 (for example) then a skinname-f0.8-0.4.zip would
have to be made.

Would this work?

-- 
Dave Brondsema 
dave@brondsema.net 
http://www.brondsema.net - personal 
http://www.splike.com - programming 
http://csx.calvin.edu - student org 

Mime
View raw message