forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Kurmanov <kurma...@openlib.org>
Subject Re: build failed with AsciiArtSVGGenerator
Date Tue, 16 Dec 2003 14:00:06 GMT
On 03-12-15, David Crossley wrote:

> Anyway, Ivan did you do a 'build clean' after you did the
> 'cvs update'?

No, I didn't.  But I tried now and it didn't change anything. 

But I found a message dated Mon, 01 Dec 2003 06:21:12 +0100
by Juan Jose Pablos with subject: "Re: cvs commit:
xml-forrest/lib/core cocoon-asciiart-block-20031129.jar
cocoon-asciiart-block-20030920.jar" 
which is a report about the same problem I have.

In a response to that one, Nicola Ken Barozzi writes: 

   You're not using java 1.4x, right? Damn, I compiled on
   1.4x :-(
   Will fix it, sorry.

So probably Nicola didn't fix that yet.


> The 'forrest seed site' works for me.
> 
> > Immediately after the message and its stacktrace it hangs.
> > Ctrl-C takes it out.  Full report is attached.
> 
> Mmmm, needing to Ctrl-C is a strange thing.


In fact, now I have slightly different behaviour.  Forrest
hangs, but Ctrl-C doesn't terminate it.  Here is what
happens: 

 1. I run forrest
 2. It reaches the favicon.ico and shows an exception
 3. it hangs
 4. I press Ctrl-C
 5. it shows: 
  
   BUILD FAILED 

   /home/ivan/forrest/xml-forrest/build/dist/shbat/forrest.build.xml:500: Java returned: 130

   Total time: 31 seconds

 and it hangs again.  At this point Ctrl-C doesn't help.  If
 I run "ps ax | grep java" I see a huge and growing list of
 java processes like that one: (separated for readability)

/usr/lib/SunJava2-1.3.1/bin/i386/native_threads/java -classpath
/home/ivan/forrest/xml-forrest/build/dist/shbat/ant/lib/ant-launcher.jar
-Dant.home=/home/ivan/forrest/xml-forrest/build/dist/shbat/ant
org.apache.tools.ant.launch.Launcher -lib
:/home/ivan/forrest/xml-forrest/build/dist/shbat/bin/../lib/endorsed/xalan-2.5.1.jar
:/home/ivan/forrest/xml-forrest/build/dist/shbat/bin/../lib/endorsed/xercesImpl-2.4.0.jar
:/home/ivan/forrest/xml-forrest/build/dist/shbat/bin/../lib/endorsed/xml-apis.jar
-buildfile /home/ivan/forrest/xml-forrest/build/dist/shbat/bin/../forrest.build.xml
-Dbasedir=/home/ivan/forrest/t1209
-Dforrest.home=/home/ivan/forrest/xml-forrest/build/dist/shbat/bin/..
-emacs seed site

  6. Ctrl-C has no effect.  What helps is "kill -s KILL <any-java-pid>".

  7. I get something like:

     /home/ivan/forrest/xml-forrest/build/dist/shbat/bin/forrest:
     line 60: 31297 Killed
     "$FORREST_HOME/ant/bin/ant" -buildfile "$ANTFILE"
     -Dbasedir="$PROJECT_HOME"
     -Dforrest.home="$FORREST_DOT_HOME" -emacs $@  

  and the happy command line prompt.


Just in case, all this happens on java 1.3 on Linux (2.4.20 kern).



Kurmanov

http://www.ahinea.com/

Mime
View raw message