forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@wkwyw.net>
Subject Re: More krysalis problems (WAS: HEAD: Krysalis-skin: some images not copied)
Date Fri, 28 Nov 2003 17:10:38 GMT
Nicola Ken Barozzi wrote:
> Ross Gardler wrote:
> ...
> 
>> The warnings about missing directories is caused by the fact that 
>> forrest.build.xml was still trying to copy content and skins from the 
>> webapp directory during the site build. The attached patch fixes this.
> 
> 
> IIRC it was in your initial patch but I did not patch this, as:
> 
>> Before applying the patch consider whether we still need to copy 
>> static content across to the build/site directory.
> 
> 
> Yes, we do.
> 
> Specifically, we need to copy all content that is not linked from any 
> page. This is how the Cocoon CLI works, it starts from index.html and 
> crawls the links that are in the *XML* sources (semantical crawling).
> 
> Thus files like CSS and JS are not "generated", as there is no xml file 
> that links them, and have to be copied by "hand", in this case by Ant.
> 
> So what we must ensure is that during _static_ generation, that is with 
> "forrest", the relevant project resources are copied to the generated 
> site locations (look in the buildfile for a comment about copying things 
> across).
> 

OK, my patch attached to this thread is closer than the original, but I 
still see a problem with it now you have explained the problem. I'll 
revisit it again - scratch the previous patch.

(actually I'm going to open up a bug for this so that we don't get 
confused about which patch is which).

Ross


Mime
View raw message