forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@wkwyw.net>
Subject Re: More krysalis problems (WAS: HEAD: Krysalis-skin: some images not copied)
Date Fri, 28 Nov 2003 15:54:47 GMT
Nicola Ken Barozzi wrote:
> Jason End wrote:
> ...
> 
>> Apart from the image problem, Krysalis isn't
>> generating the mini-toc in the left menu, and in my
>> pages main index.html, it doesn't add a pdf image/link
>> (it does add the pdf link in other files)
>> I built the site using the default forrest skin and
>> both these elements work correctly, so I don't think
>> it's due to any errors in my xmls.
> 
> 
> Ok, I'll check, thanks for reporting. Oh, and also thanks for the way 
> it's written, I always like reports like this that contain all the main 
> information and even a suggestion :-)

The warnings about missing directories is caused by the fact that 
forrest.build.xml was still trying to copy content and skins from the 
webapp directory during the site build. The attached patch fixes this.

Before applying the patch consider whether we still need to copy static 
content across to the build/site directory. I don't think we do as 
Cocoon will copy this stuff across when building. However, I'm not sure 
why this was introduced in the first place so I've left it in.

However, this does not fix the problem with the missing images and 
broken mini-toc. I suspect these bugs were introduced by my patch and I 
have some time today so I'm looking at it now. Nikola Ken, if you have 
made progress let me know I'm wasting my time (assuming you read this mail).

Ross

Mime
View raw message