forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: FIXED: Last link missing in CLI
Date Sun, 21 Sep 2003 07:46:03 GMT
On Sun, Sep 21, 2003 at 05:29:05PM +1000, David Crossley wrote:
> Upayavira wrote:
> > Jeff Turner wrote:
> > >Upayavira wrote:
> > >>Simon Meith just provided a patch to fix the bug with the last link not

> > >>being present when a site is generated with the CLI. I've patched the 
> > >>current Cocoon CVS. Many thanks to Simon - it was far more 
> > >>straight-forward than I would have expected.
> > >
> > >Great!  I tried it with my site that had missing pages and it fixes the
> > >problem.  I've committed it to Forrest CVS.
> > >
> > >All: I'd like to make a 0.5.1 Forrest release with this and other fixes.
> > >
> > Wow. It warrants a new Forrest release! That's something ;-)
> 
> Brilliant. Thanks to everyone. When do we add a new "stable-" tag?
> That issue seemed to be the main one to solve.

And the obfuscated-emails, which I'm working on now..
 
> > >If you see a bugfix patch that would benefit 0.5 users, please port it to
> > >the FORREST_05_BRANCH branch. ...
> <snip/>
> 
> So does "porting" just mean adding that tag to the files in question
> or is there an actual "branch" of CVS?

There is an actual branch, called FORREST_05_BRANCH.  Its contents should
always be 'stable'.  I did the following:

cp -r xml-forrest xml-forrest-0.5.1
cd xml-forrest-0.5.1
cvs update -r FORREST_05_BRANCH

And then to merge a change from the CVS trunk to the branch:

 - Go to xml-forrest-0.5.1/... 
 - Run cvs up -j HEAD <file to pull in from the trunk>
 - Commit


--Jeff


> 
> --David
> 

Mime
View raw message