forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: Failed build
Date Sat, 20 Sep 2003 08:27:27 GMT
On Sat, Sep 20, 2003 at 09:07:24AM +1000, Glen Stampoultzis wrote:
> 
> Hi,
> 
> when I call forrest from another ant build file using the document 
> procedure I get a problem where the forrest build fails but my parent build 
> passes.  Is there anyway to fail the parent build if the forrest build 
> fails?

The problem is that forrest.antproxy.xml uses the old Cocoon
command-line.  I forgot to update it when updating forrest.build.xml.
The new CLI class returns a nonzero exit code if pages fail.  I'll fix
this ASAP.

--Jeff

> Here's what's happening:
> 
> -----------------------------8<-------------------------------
>      [java] * [0] trans/es/images/add.jpg
>      [java] * [0] references/index.pdf
>      [java] * [0] resources/images/group-logo.gif
>      [java] * [0] images/unknown.jpg
>      [java] Total time: 0 minutes 57 seconds
> 
>      [java] BUILD FAILED
>      [java] /home/glens/forrest/forrest.build.xml:631: Java returned: 1
> 
>      [java] Total time: 1 minute 16 seconds
>      [java] Java Result: 1
>      [echo] Broken links:
> 
> site:
> 
> BUILD SUCCESSFUL
> Total time: 6 minutes 32 seconds
> -----------------------------8<-------------------------------
> 
> 
> 
> Glen Stampoultzis
> gstamp@iinet.net.au
> http://members.iinet.net.au/~gstamp/glen/
> 

Mime
View raw message