forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Jack" <aj...@trysybase.com>
Subject Can't seem to get my forrest configured...
Date Wed, 24 Sep 2003 21:15:26 GMT
Hi,
I am trying to finish off Python Gump to create xdocs for it's output see:
 http://nagoya.apache.org/wiki/apachewiki.cgi?GumpPython.

I have the basics working, but none of the "prettiness".

I have a template structure I copy into a working directory, and then I fill
w/ dynamically created xdocs. This is the template tree (under forrest):

forrest
forrest/src
forrest/src/documentation
forrest/src/documentation/content
forrest/src/documentation/content/xdocs
forrest/src/documentation/content/xdocs/site.xml
forrest/src/documentation/content/xdocs/tabs.xml
forrest/src/documentation/skinconf.xml
forrest/src/documentation/resources
forrest/src/documentation/resources/images
forrest/src/documentation/resources/images/group-logo.gif
forrest/src/documentation/resources/images/group.svg
forrest/src/documentation/resources/images/icon.png
forrest/src/documentation/resources/images/project-logo.gif
forrest/src/documentation/resources/images/project.svg
forrest/forrest-targets.ent
forrest/forrest.properties
forrest/status.xml

[BTW: I tried using "forrest seed" but that was a tad too raw, I wanted
Jakarta Gump look and feel.]

I've tried turning off printing, PDF, search, and adding logos. Nothing
seems to work for me. I tried non-standard hierarchies but now I am back to
trying the standard src/documentation one, and I've checked it against a
seeded forrest, and it eyeballs ok (to me).

I am sure it is (somehow) me/my structure, but I can't seem to figure it
out. Please look at these two for output, and run output.

http://gump.chalko.com/py/
http://gump.chalko.com/py/gumpy.html (see forrest stuff at bottom)

[Note: These are out of date as of this exact mo, an older structure, but
will update shortly, it is running...]

I do :
Step #1) Copy:
cp -Rf /home/share/gump/local-gump/template/forrest
/home/share/gump/gump-work/py
Step #2) Populate xdocs (run gump and build xdocs into
src/documentation/content/xdocs)
Step #3) Launch Forrest:
cd /home/share/gump/gump-work/py/forrest

forrest -Djava.awt.headless=true -Dproject.site-dir=/home/share/gump/www/py

Can anybody help me figure out what is wrong here? Do I need more
parameters? [I've tried many from the doc site.] Do I have the wrong CWD?

Is there any way I can get forrest to tell me what I am doing wrong? [I
tried -debug, but that seemed too verbose, verbose seemed anty not
forresty.] Maybe it is telling me, maybe I'm just not seeing it.

Thanks in advance for any help.

regards,

Adam


Mime
View raw message