forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From g4 <ja...@root10.net>
Subject Re: XSP in forrest
Date Sun, 13 Jul 2003 13:05:22 GMT

On Sunday, Jul 13, 2003, at 06:14 Europe/London, Jeff Turner wrote:

> Hi,

Hi list, hi Jeff.

I worked through this last week, the only way I could Forrest to 
upgrade was by the following. It seems to have worked except that I get 
a "resource not found" when I try to access a XSP. So I guess I've got 
it completely wrong or am missing something.

1.	Get Cocoon-2.1 from CVS
2	Get Forrest from CVS
3 	Get the source dists. of NEKODTD & NEKOPULL these are available from;
	http://www.apache.org/~andyc/neko/nekodtd-latest.tar.gz
	http://www.apache.org/~andyc/neko/nekopull-latest.tar.gz

	and extract

	All these (1,2 & 3) should live on the same level (same folder), you 
should now have the following folders:

	cocoon-2.1
	xml-forrest
	nekodtd-0.1.6
	nekopull-0.2.3

4.	Edit local.blocks.properties and un-comment all the blocks you want 
to appear in Forrest
5.	Copy this file amended file to */cocoon-2.1/
6.	Build Cocoon
7.	Amend */xml-forrest/etc/cocoon_upgrade/upgrade_cocoon_jars.sh to 
include all the blocks required for example:
	
	bzcopy session-fw
	#cocoon-session-fw-block.jar
	bzcopy authentication-fw
	#cocoon-authentication-fw-block.jar
	bzcopy xmldb
	#cocoon-xmldb.jar
	bzcopy xmlform
	#cocoon-xmlform-block.jar

8.	run upgrade_cocoon_jars.sh and you should see it CVS diffi'ng 
against your CVS version of Cocoon, it takes a while 5- mins or so.

9.	Now build forrest.

I now have all the blocks there, however they are now re-named for 
example to:

cocoon-xmldb-block-20030711.jar
cocoon-xmlform-block-20030711.jar

Also looking at Forrest cocoon.xconf I see that all references to XSP 
are now included within <markup-languages/>.

Let me know if you think this is right. Also if you have any insight 
into why I'm getting a "resource not found" on XSP's.

Many thanks



>
> I don't think you have the latest versions of all the software.
>
> You need to:
>  - Check out the latest Forrest from CVS.  See
>    http://xml.apache.org/forrest/your-project.html#getting_from_source
>  - Check out the latest Cocoon from CVS, or download the M3 
> distribution.
>  - In xml-forrest/etc/cocoon_upgrade, customize and run the script.
>
>
> --Jeff
>
> On Sat, Jul 12, 2003 at 07:17:38AM -0400, Leo wrote:
>> Hello
>>
>> I want to enable XSP in Forrest.
>> I am using Forrest 0.4 ( Source distribution).
>>
>> I am trying to follow advice given by Jeff Turner on
>> Tue Jul 08, 2003:
>>
>>
>> Hacking cocoon.xconf is an overrated pastime.  I'd suggest checking 
>> out
>> CVS (or M3) Cocoon, and rebuilding it with the XMLForm block included.
>> This can be done by copying the etc/cocoon-local.blocks.properties 
>> file
>> from Forrest into the Cocoon root, commenting out the xmlform exclude,
>> and rebuilding Cocoon.  Then in Forrest, run the
>> etc/cocoon_upgrade/upgrade_cocoon_jars.sh script, and generate a 
>> webapp
>> to play with.
>>
>>
>> I am not finding directory:etc in Forrest
>> so can't access cocoon-local.properties file
>> or /cocoon-upgrade/upgrade_cocoon_jars.sh script
>>
>> Checked thread : Re : upgrade_cocoon.jars.sh
>> but am not understanding.
>>
>> Thanks in advance
>> Leo
>
>
Jason Lane

Developer
Root10 developments

Mime
View raw message