forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BERGER Arnaud <A.BER...@tiscalicontact.fr>
Subject RE: xlinks not working ins SVG ?
Date Thu, 17 Jul 2003 15:40:10 GMT


Sorry for the huge files from last post

Well here is a simple svg with an image (the image is needed
to show you the problem)

This image must be in the same directory as the svg.

Regards,

Arnaud
 
> BERGER Arnaud wrote:
> 
>>Hi everyone,
>>
>>Here I have JDK1.4.1 with Windows 2000 .
>>
>>I've got a problem with the CVS forrest I've downloaded 2 days ago.
>>
>>The SVG files which contain "xlink:href " are not correctly rendered.
>>With the exact same files, I had no problem with my last CVS forrest 0.5
>>(downloaded one month ago).
>>
>>
>>Here is an example :
>>
>> <svg xmlns="http://www.w3.org/2000/svg"
>>  xmlns:xlink="http://www.w3.org/1999/xlink"
>>  width="286" height="84" viewBox="0 0 286 84">
>>	<image x="69" y="48" width="286" height="84"
>>xlink:href="..\someImage.jpg"
>>		transform="translate(-17.5 -48.5) translate(-52 0.5)"/>
>>	<text fill="rgb(128,0,128)" font-size="16" font-family="Trebuchet"
>>		font-weight="bold" x="198px" y="72px"
>>transform="translate(-10 0.5)">CONTACT</text>
>></svg>
>>
>>this SVG file appears with a "broken image" icon, but the text ("contact")
>>appears correctly.
>>the jpg image is at the right place, and the SVG shows correctly with
>>Batik's browser
>>( 1.5 beta 5 )
>>
>>
>>Here is another example (well, only the offensing part of it)
>>
>>.....
>><g id="arrow" transform="scale(0.8) translate(-28.5 -32.5)">
>>	.....		
>>		</g>
>><g id="graphics" >
>><rect x="-5%" width="110%" height="185"/>
>><circle cx="50%" cy="140" r="85"/>
>><use xlink:href="#arrow" x="225" y="260"/>
>></g>
>>
>>In that case, I get a
>>  "   org.apache.batik.bridge.BridgeException: null:-1
>>An I/O error
>>      occured while processing the URI '#arrow' specified on the e
>>     lement <use>"
>>when executing "forrest site".
>>Here again, the SVG shows correctly with Batik's browser.
>>
>>Both files were unchanged since I used them with CVS forrest from
> 
> May-June,
> 
>>and after some googlization, it seems like their may be a problem yet with
>>external references in SVG.
>>
>>I don't know which forrest's changes may have changed this behavior.
>>
>>Thanks in advance for any help,
>>
>>Regards,
>>
>>       Arnaud
> 
> 
> 
> 
> ------------------------------------------------------------------------
> 
> 
> ------------------------------------------------------------------------
> 



Mime
View raw message