forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Jose Pablos <che...@che-che.com>
Subject Re: tabs, and site.xml problem
Date Thu, 10 Jul 2003 17:15:10 GMT
Antonio,

Make sure that you have a site element with a index.html file in it. i.e:

<site>
<about label="About" tab="home" >
<foo label="Foo" href="index.html"/>
</about>
</site>

or:
<site>
<about label="About" href="index.html" tab="home" />
</site>

but not:

<site>
<about label="About" tab="home" >
<foo label="Foo" href="foo.html"
</about>
</site>

It is weird...

Cheers

cheche

Antonio Gallardo wrote:
> Hi:
> 
> I am still having problem with this. Can someone help.
> 
> Best Regards,
> 
> Antonio Gallardo
> 
> -------- Mensaje Original --------
> Asunto: Re: tabs, and site.xml versus book.xml
> De: "Antonio Gallardo" <agallardo@agsoftware.dnsalias.com>
> Fecha: Mar, 8 de Julio de 2003, 10:33
> Para: <forrest-dev@xml.apache.org>
> 
> Jeff Turner dijo:
> 
> 
>>    - (advanced) The '' tab is special, and matches all nodes.  The
>>root
>>      <site> node contains no tab attribute.  It therefore defaults to
>>'', and so the front page contains links to all pages.  Usually, you'd
>>use <site tab="home">, and call the home tab 'home', in
>>which case only a subset of the site's content would appear on the
>>home tab.
> 
> 
> Hi:
> 
> I already done <site tab="home"> with no results:
> 
> <site label="SIG" href="" xmlns="http://apache.org/forrest/linkmap/1.0"
> tab="home">
> 
> I always get all the site menu in the home tab.
> 
> I also uncommented project.menu-scheme=tab_attributes in
> forrest.properties file.
> 
> I am using project.skin=krysalis-site
> 
> What I am doing wrong?
> 
> Best Regards,
> 
> Antonio Gallardo
> 
> 



Mime
View raw message