forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: Error when trying to run forrest seed
Date Sun, 27 Jul 2003 12:20:30 GMT
On Sun, Jul 27, 2003 at 07:34:31AM -0400, Leo wrote:
> 
> On Sat, Jul 26, 2003 at 06:37:42PM -0400, Leo wrote:
> > Hi folks
> >
> > (1)
> > I had downloaded forrest and was able to sucessfully do the following:
> > -run forrest build
> > -Create my own directory and run
> > 	forrest seed
> > 	forrest site
> > 	forrest webapp
> > 	forrest run
> >
> > (2)
> > However forrest run: gave me a "java.lang.NoClassDefFoundError:"
> 
> What was the actual error?  It can probably be found in
> build/tmp/context/WEB-INF/logs/error.log.
> 
> --Jeff
> 
> **********
> Leo wrote:
> **********
> 
> Error.log file is empty now, but below is partial screen print of error
> observed.
> 18:04:58.617 EVENT  org.exist.DatabaseAdminServlet: DatabaseAdminServlet:
> exist.
> home=C:\MyForrest\build\webapp\WEB-INF
> 18:04:58.617 EVENT  org.exist.DatabaseAdminServlet: reading configuration
> from C
> :\MyForrest\build\webapp\WEB-INF\conf.xml
> java.lang.NoClassDefFoundError:
> it/unimi/dsi/fastutil/Object2ObjectOpenHashMap
>         at org.exist.storage.IndexPaths.<clinit>(IndexPaths.java:41)
>         at org.exist.util.Configuration.<init>(Configuration.java:174)
> 
> 
> I am trying to get Exist to work with Forrest.

Extra jars should go in Forrest's lib/core/.  When the Forrest
distribution is built, they will be copied to
$FORREST_HOME/build/dist/shbat/WEB-INF/lib/, and from _there_, they will
end up in either build/tmp/context/WEB-INF/lib/ or
build/webapp/WEB-INF/lib/, depending on whether you render the site
statically ('forrest site') or dynamically ('forrest run').


--Jeff

Mime
View raw message