forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Jose Pablos <che...@che-che.com>
Subject Re: Navigation problem
Date Wed, 30 Apr 2003 14:22:15 GMT
Jeff,

I tried your demo, and these are the errors I found:

after cvs update -d

./build.sh

when I run forrest -v validate on the xinclude-demo directory.


java.io.FileNotFoundException: 
/var/tmp/xinclude-demo/src/documentation/content/xdocs/document-v11-xinclude.dtd 
(No such file or directory)
	at java.io.FileInputStream.open(Native Method)


I fixed overwriting the catalog properties on forrest.properties.


cheche@carolo:/var/tmp/xinclude-demo$ diff forrest.properties.old 
forrest.properties
26c26
< #project.content-dir=src/documentation
---
 > project.content-dir=src/documentation
32c32
< #project.schema-dir=${project.content-dir}/resources/schema
---
 > project.schema-dir=${project.content-dir}/resources/schema
43c43
< #project.catalog=${project.schema-dir}/catalog
---
 > project.catalog=${project.schema-dir}/catalog

After I runned again, I got this error message:


Error at URL 
"file:/var/tmp/xinclude-demo/src/documentation/sitemap.xmap", line 
number 133, column number 40: element "pipelines" from namespace 
"http://apache.org/cocoon/sitemap/1.0" not allowed in this context

am I doing something wrong?

Cheers

Cheche


Jeff Turner wrote:
> On Wed, Apr 30, 2003 at 01:34:45PM +0200, Ines Robbers wrote:
> 
>>Hi!
>>I'm afraid it's still not working..
>>When I try to open index.html I get:
>>
>>type resource-not-found
>>message Page Not Available.
>>description The requested resource couldn't be found.
>>sender org.apache.cocoon.bean.CocoonBean
>>source Cocoon commandline (Main.java)
>>request-uri
>>index.html
>>missing-file
>>index.html
> 
> 
> Do regular sites (Forrest's own, and the seed site) work?  For instance,
> try creating a new directory:
> 
> C:\Dokumente und Einstellungen\Ines Robbers\Eigene Dateien\ForrestProjekte\test
> 
> and then run 'forrest seed site' in it.  That should work.  If not,
> perhaps try the same in C:\test to ensure the spaces in the path aren't
> breaking things.
> 
> 
>>I don't know - does it perhaps have to do with the fact that I am using
>>Cocoon 2.1?
> 
> 
> All Forrest releases have used 2.1.
> 
> --Jeff
> 
> 
>>Ines
>>



Mime
View raw message