forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: inconsistent buggy behaviour between CLI and Jetty
Date Thu, 20 Mar 2003 11:25:21 GMT
On Wed, Mar 19, 2003 at 05:23:03PM +0100, Steven Noels wrote:
> Folks,
> 
> ... caused by some lower-down-the-line exception:
> 
> Caused by: org.apache.cocoon.ResourceNotFoundException: No pipeline 
> matched request: whoweare/tab-index.xml
...

:/  Well possibly the Cocoon redirect behaviour changed, but equally
possibly, the changed sitemap has triggered a bug somehow.

> I've been looking into various places of the various (hehe) sitemaps, 
> but cannot easily locate where to look.

At the bottom of sitemap.xmap, there is a long list of patterns to match,
whose handling is delegated to subsitemaps.  There you'll find:

  <map:match pattern="**/">
    <map:mount uri-prefix="" src="redirect.xmap" check-reload="yes" />
  </map:match>

redirect.xmap has:

  <map:match pattern="**/">
    <map:redirect-to uri="{request:contextPath}/{1}/index.html"/>
  </map:match>

I can't see anything wrong with this, or how it differs from the old
sitemap (in src/resources/conf/old/).

Perhaps if we ignore the problem, it will go away.  There's a new CLI in
the works.  Hrm..


--Jeff

> Mind you I'm not using site.xml yet, and would like to get things up & 
> running first with simple book.xml's
> 
> Any idea?
> 
> </Steven>

Mime
View raw message