forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: forrest webapp install fails for 0.4 release
Date Sat, 15 Feb 2003 01:24:52 GMT
On Fri, Feb 14, 2003 at 08:28:08AM -0900, Matt Jones wrote:
> Hi,
> 
> I just downloaded forrest 0.4 and tried to install the webapp on a clean 
> machine.  After running 'forrest webapp' and configuring it in Tomcat 
> 3.3.1a, I tried to access the webapp and got a ClassNotFoundException 
> for a xerces class.
> 
> It turns out that neither the xml-apis.jar nor the xercesImpl.jar were 
> copied over to the webapp/WEB-INF/lib directory.  Looking at the forrest 
> build file, it seems that these files are not copied if one is using 
> jdk1.4+.  I am using jdk1.4.1_01 on linux.  By manually copying those 
> two jars across from forrest, the webapp then worked flawlessly.
> 
> Is there another way I should have fixed this?  Can the webapp target be 
> patched to copy these jar files as well, even under jdk1.4+?  If 
> jdk1.4.1 is supposed to contain a copy of these jars already, do you 
> have any ideas as to why weren't they found on my classpath?

JDK 1.4 comes with the Crimson XML parser, and an old buggy version of
Xalan.  Forrest requires Xerces (some XNI stuff) and a more recent
version of Xalan.

With Tomcat 3.x, this can be achieved by setting:

export TOMCAT_OPTS=-Djava.endorsed.dirs=$FORREST_HOME/lib/endorsed

Or (I think) copying the $FORREST_HOME/lib/endorsed/*.jar files into
$JAVA_HOME/jre/lib/endorsed

HTH,

--Jeff

> Thanks,
> Matt
> 

Mime
View raw message