forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From je...@apache.org
Subject cvs commit: xml-forrest/src/documentation/content/xdocs faq.xml
Date Sun, 12 Jan 2003 12:47:03 GMT
jefft       2003/01/12 04:47:03

  Modified:    src/documentation/content/xdocs faq.xml
  Log:
  Add an entry dealing with rendering site.xml-using projects with versions of
  Forrest that don't support site.xml.
  
  Revision  Changes    Path
  1.18      +22 -0     xml-forrest/src/documentation/content/xdocs/faq.xml
  
  Index: faq.xml
  ===================================================================
  RCS file: /home/cvs/xml-forrest/src/documentation/content/xdocs/faq.xml,v
  retrieving revision 1.17
  retrieving revision 1.18
  diff -u -r1.17 -r1.18
  --- faq.xml	8 Jan 2003 05:44:32 -0000	1.17
  +++ faq.xml	12 Jan 2003 12:47:03 -0000	1.18
  @@ -4,6 +4,28 @@
   <faqs title="Frequently Asked Questions">
   
   <faq>
  +  <question>
  +    When building my project, I get an validation error: <code>Document root
  +      element "site", must match DOCTYPE root "null".</code>.
  +  </question>
  +  <answer>
  +    <p>
  +      You are probably trying to build the project with an old version of
  +      Forrest (built before 2003-01-08) that is incorrectly trying to validate
  +      the <code>site.xml</code> file.  If so, please update your Forrest
  +      installation.
  +    </p>
  +    <p>
  +      Alternatively, you may be building with an up-to-date Forrest, but have
  +      overridden <code>forrest.validate.xdocs.excludes</code> in
  +      <code>forrest.properties</code>.  With the introduction of
  +      <code>site.xml</code>, the above property must have <code>site.xml</code>
  +      listed to prevent an attempt at DTD-based validation.
  +    </p>
  +  </answer>
  +</faq>
  +
  +<faq>
    <question>
     Why do the generated documents look a little strange?
    </question>
  
  
  

Mime
View raw message