forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [issues] New comment: (FOR-10) build dist fails (both in windows-cmd and cygwin)
Date Thu, 01 Jan 1970 00:00:00 GMT
The following comment has been added to this issue:

     Author: Fergus Henderson
    Created: Sun, 26 Jan 2003 11:14 PM
       Body:
I got a similar error ("C:\cygwin\bin\cygpath.exe: *** can't create title mutex, Win32 error
6)" when compiling a completely different
package, namely Mercury 0.11.0 <http://www.cs.mu.oz.au/mercury/>,
with Cygwin.  The error was reproduceable. It looks very much
like this is a Cygwin bug rather than anything to do with Apache
or Mercury.

If you figure out how to fix it or even work around it,
please let me (fjh at cs.mu.oz.au) know!
---------------------------------------------------------------------
View the issue:

  http://issues.cocoondev.org/jira//secure/ViewIssue.jspa?key=FOR-10


Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-10
    Summary: build dist fails (both in windows-cmd and cygwin)
       Type: Bug

     Status: Unassigned
   Priority: Major

    Project: Forrest
  Component: Building Forrest

   Assignee: 
   Reporter: Ralf Hauser

    Created: Thu, 9 Jan 2003 1:12 PM
    Updated: Thu, 9 Jan 2003 1:12 PM
Environment: win2k with cygwin and cmd
no clue which version of forest cvs got on my c:

Description:
1) cygwin:
rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest> ./build.sh dist
Using classpath: "./lib/endorsed/xalan-2.4.1.jar;./lib/endorsed/xercesImpl-2.1.0
.jar;./lib/endorsed/xml-apis.jar;./lib/endorsed/xsltc.jar"
C:\Data\MyDocRalf\bin\cgywin\bin\cygpath.exe: *** can't create title mutex, Win32 error 6
Error: JAVA_HOME is not defined correctly.
  We cannot execute java
rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest>

Any idea what happened? Otherwise, I can run ant and other java stuff without problems. Since
I updated to cygwin1.18, man doesn't find all
directories in the man path anymore - perhaps this mutex is a cygwin problem and has notthing
to do with forrest?

2) Win32 cmd:
C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest>build dist
Using classpath: ";.\lib\endorsed\xalan-2.4.1.jar;.\lib\endorsed\xercesImpl-2.1.
0.jar;.\lib\endorsed\xml-apis.jar;.\lib\endorsed\xsltc.jar"
Buildfile: build.xml

init:

      --------------------------------------------------------------

      Using Apache Ant version 1.6alpha compiled on December 1 2002
      Build file C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build.xml

      Build system home tools\ant
      Build number 0
      Project Name Forrest build file
      Java Version 1.3
      Timestamp 200301091951

      --------------------------------------------------------------

Created dir: C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build

validate-config:
validating **/skinconf.xml ...
Fatal error: exception "java.io.FileNotFoundException" thrown: C:\Data\MyDocRalf
\bin\Java\apache_forrest\xml-forrest\src\resources\schema\relaxng\skinconf-v10.rng (The system
cannot find the file specified)

BUILD FAILED
file://C:/Data/MyDocRalf/bin/Java/apache_forrest/xml-forrest/build.xml:305: Vali
dation failed, messages should have been provided.

Total time: 4 seconds

C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest>

It appears that there is a typo - I do have a skinconf.rnc, but not skinconf.rn*G*


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org/jira//Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message