forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Vaterlaus <mvaterl...@mus.ch>
Subject Re: Using forrest as an webapp
Date Wed, 20 Nov 2002 19:58:53 GMT
>>Hi list,
>>
>>I tried this evening to use forrest as an webapp within tomcat. Now 
>>I can't figure out why I failed. Maybe some member of this list 
>>knows more.
>
>
>Markus,
>
>See this thread:
>
>http://marc.theaimsgroup.com/?l=forrest-dev&m=103722010001882&w=2
>
>I just had this problem come up almost exactly a week ago. Hope this helps.
>
>
>Tony

Hi Tony, hi list,

thank you for your fast response. Allthough, it looks like the same 
problem, it didn't help that much. My Forrest Webapp still doesn't 
work. Maybe I'm doing something wrong or I've missed something or I'm 
totally clueless and better should play around with my lego mindstorm 
set (found one today in a second hand boutique) ;-)

... at the end of the above mentioned thread Jeff Turner wrote
>
>Also, for anyone else having trouble with the webapp: it breaks under JDK 1.3
>because lib/endorsed/*.jar isn't copied into WEB-INF/lib.  This is 
>fixed in CVS
>and will be in 0.2 final.

As I'm using 1.3.1 I looked at this closely. So in my webapp build 
under 
/Users/mv/dwnld/forrestcvs/xml-forrest/build/webapp/WEB-INF/lib/endorsed 
( webapp is reffered as a context in tomcat) there are four files 
(xalan-2.3.1.jar, xml-apis.jar, xercesImpl-2.1.0.jar and 
xsltc-20020723.jar). However, after deleting the "work" directory of 
tomcat and restarting it, I get the same error as yesterday. That's 
quite confusing for me, 'cause I'm used to use tomcat "as is" with 
cocoon deployed from a war-file.

I appreciate your help.

Markus






Mime
View raw message