forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: Cache problems with cocoon
Date Sat, 09 Nov 2002 09:12:23 GMT
On Fri, Nov 08, 2002 at 06:10:56PM +0100, Carles Canellas wrote:
> Hello, I have solved my caching problems in webapp
> mode.
> The secret was comment that lines in cocoon.xconf
>  <persistent-store
> class="org.apache.cocoon.components.store.JispFilesystemStore"
>                     logger="core.store.persistent">
>     <parameter name="use-cache-directory"
> value="true"/>
>     <parameter name="datafile"
> value="cocoon-cache.dat"/>
>     <parameter name="indexfile"
> value="cocoon-cache.idx"/>
>     <parameter name="order" value="1701"/>
>   </persistent-store>
> 
> And everything worked OK.

I've been doing some experimenting..  How did you know when things were
fixed?  I'd have expected something like this in sitemap.log:

Found cached response for 'index.html'

Whether the Jisp block is in or out, I never see that.  Also, if I add a
marker comment to site2xhtml.xsl:

<xsl:template match="site">
  <xsl:message>## Reapplying site2html.xsl stylesheet</xsl:message>

It prints on Tomcat's stdout on every request.

I added the same <xsl:message> to a stylesheet in Cocoon's documentation
webapp, and it seems to also be reapplied on every request.  Perhaps this
is a C2.1 bug that no-one's noticed yet.. 


--Jeff


> So If somebody is trying to use forrest in dynamic
> way, that's the patch to do (I don't asume it's a
> patch, because in static forrest with CLI perhaps it
> works ok that way)
> 
> 
> 
> =====
> Carles Canellas.
> VicerTec S.L.
> 

Mime
View raw message