forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Blizard <b...@samsungcontact.com>
Subject Re: Classnotfound when running ./build.sh docs
Date Thu, 10 Oct 2002 14:17:42 GMT
Interesting, changing jdk to 1.3 made the errors fade away.

expect big things.

-Buzz.

Jeff Turner wrote:

>On Thu, Oct 10, 2002 at 12:51:45PM +0100, Ian Blizard wrote:
>  
>
>>Hi all.
>>
>>I'm interested in helping with/contributing to the Forrest project, 
>>however I cannot seem to generate the documents from the build.sh script 
>>I always encounter this error:
>>
>>Setup... done.
>>
>>Initializing... ready, let's go :-)
>>
>>java.lang.ClassNotFoundException: 
>>org/apache/xml/dtm/ref/IncrementalSAXSource_Xerces
>>    
>>
>
>Hmm.. you don't have a Xerces lurking in your JDK lib/ext or lib/endorsed
>(?) directories?
>
>It would be helpful to see the output of running Ant with '-v' (verbose)
>to see exactly what the classpath for Forrest is.
>
>  
>
>>Which is a shame.
>>
>>Everything seems to run A.O.K using the deployed Forrest.war in Tomcat.
>>
>>I'm using jdk1.4.0_02 and ant 1.5.1
>>
>>Any help would be greatly appreciated.
>>
>>Any more news on acorn?  This looked really handy if I just wanted to 
>>create my own site...
>>    
>>
>
>As of this afternoon, acorn-like functionality is part of the default
>build. To get a new site, you'd do:
>
>~/xml-forrest$ ./build.sh dist
>~/xml-forrest$ export PATH=$PATH:`pwd`/build/dist/shbat/bin
>~/xml-forrest$ cd /tmp
>/tmp$ mkdir mysite
>/tmp$ cd mysite
>/tmp/mysite$ forrest.sh seed     # Creates a template project
>/tmp/mysite$ forrest.sh          # Creates does for the new site
>
>
>--Jeff
>
>  
>
>>-Buzz.
>>
>>    
>>



Mime
View raw message