forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Portier" <...@outerthought.org>
Subject RE: cvs commit: xml-forrest/src/documentation/content/xdocs/community/howto/cvs-ssh howto-cvs-ssh.xml
Date Fri, 16 Aug 2002 10:01:49 GMT
> > > >   Added the line (%chmod 700 ~/.ssh) in
> > > described ssh setup
> > > > on remote host.
> > > >   Tests proved the drwx------ setting to be an
> > > absolute must
> > > > to get things working.
> > >
> > > Can't remember that I've ever used this command
> > > during setup of SSH.
> > >
> >
> > maybe your umask covered it?
> > tests showed the need for the drwx------  and
> this makes it
> > independent of how the umask is set I guess.
> >
> > mmmm, I have to give in: there is more to it...
> > on cvs.apache server it works regardless of the
> settings on
> > the .ssh :-(
>
> Yes, I've tried it on cvs.apache.org only.
>

Obviously I didn't do the full range test on all servers
around.
I did some more now, also on cvs.apache.org

and it looks like 700 is a bit to picky, a simple:
chmod go-w .ssh
should do the job

(I just tried the chmod go+w .ssh on cvs.apache and after
that it prompts for the pwd again...
 DON'T TRY THIS AT HOME UNLESS YOU STILL REMEMBER THAT
PASSWORD YOU NEVER USE :-)
 so it is less version/platform dependent than my previous
message implied, I guess)

letting it at the even more restrictive 700 doesn't look
like bad practice
(although 755, 744, 745 and 754 would work as well)

regards,
-marc=

> >
> > sorry for stepping in so bluntly,
> > mmm, the change makes it work on more
> environments, but he
> > wording could be made intellectually more correct maybe?
> > I'm doing some more tests first now...
>
> No problems.
> If your setting covers mine too and works in more
> environments then let's
> leave it as you've changed. I suspect that it
> depends on the SSH version
> used on the server.
>
> Konstantin
>


Mime
View raw message