forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: [PATCH] acorn.xml: bootstrapping new projects
Date Sun, 18 Aug 2002 11:32:22 GMT
On Sun, Aug 18, 2002 at 06:09:13PM +1000, David Crossley wrote:
> Thanks for the "acorn" idea (love the metaphor) and the patch.
> We will look into it ASAP. I have it running on my system.
> 
> More below ...
> 
> Jeff Turner wrote:
> > Marc Portier wrote:
> > ...
> > > On this very topic, my analysis at this stage would be:
> > > There is currently too much coupling between the forrest
> > > build.xml and the generation of the docs.
> > 
> > Yep :) There's no separation between "building Forrest" and "building a
> > website's docs with Forrest". Consequently, anyone wanting to use Forrest
> > has to first dig through build.xml to separate the forresty bits from the
> > build system.
> 
> Did you see the document "forrestbot.html"? I did not need to
> tweak anything in build.xml ... the bot works beautifully for me.
> While i established it on my system today, i added a new document
> as a concise overview.

I saw forrestbot, and thought it looked cool, but more relevant for when one
wants to update a live website, rather than just build local project docs.

Thanks for writing the overview. It's exactly this last 5% that people need.
Probably I'm just doing something stupid, but it didn't work for me. I followed
the instructions in your-project.xml, and when I ran:

./build.sh bot
-Dbot.forrestbot.xconf=/home/jeff/testproj/testproj.conf.xml
-Dtemplate.echo=true

in my xml-forrest (clean build/)

URI: changes.html
  getting links: .  [broken link]--> images/group-logo.gif
  [broken link]--> images/project-logo.gif
  [broken link]--> images/add.jpg
ERROR   2002-08-18 20:55:57.978 [sitemap ] (): Error while processing pipeline at file:/old/home/jeff/homeoverflow/apache/xml/xml-forrest/build/bot/projects/myproj-local/context/./sitemap.xmap:135:17
org.apache.cocoon.ProcessingException: Failed to execute pipeline.: org.apache.cocoon.ResourceNotFoundException:
Resource not found.: org.apache.excalibur.source.SourceNotFoundException: Resource not found
file:/old/home/jeff/homeoverflow/apache/xml/xml-forrest/build/bot/projects/myproj-local/context/./content/xdocs/your-project.xml

Which is bizarre, since your-project.xml certainly isn't mentioned anywhere in
my test project. However, running just './build.sh bot' worked fine, so I'm
sure it's something minor.


--Jeff

Mime
View raw message