forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@indexgeo.com.au>
Subject using ForrestBot (Was: [PATCH] acorn.xml: bootstrapping new projects)
Date Mon, 19 Aug 2002 04:04:18 GMT
Jeff Turner wrote:
> David Crossley wrote:
> > Did you see the document "forrestbot.html"? I did not need to
> > tweak anything in build.xml ... the bot works beautifully for me.
> > While i established it on my system today, i added a new document
> > as a concise overview.
> 
> I saw forrestbot, and thought it looked cool, but more relevant for when one
> wants to update a live website, rather than just build local project docs.
> 
> Thanks for writing the overview. It's exactly this last 5% that people need.
> Probably I'm just doing something stupid, but it didn't work for me. I followed
> the instructions in your-project.xml, and when I ran:
> 
> ./build.sh bot
> -Dbot.forrestbot.xconf=/home/jeff/testproj/testproj.conf.xml
> -Dtemplate.echo=true
> 
> in my xml-forrest (clean build/)
> 
> URI: changes.html
>   getting links: .  [broken link]--> images/group-logo.gif
>   [broken link]--> images/project-logo.gif
>   [broken link]--> images/add.jpg
> ERROR   2002-08-18 20:55:57.978 [sitemap ] (): Error while processing pipeline at file:/old/home/jeff/homeoverflow/apache/xml/xml-forrest/build/bot/projects/myproj-local/context/./sitemap.xmap:135:17
> org.apache.cocoon.ProcessingException: Failed to execute pipeline.: org.apache.cocoon.ResourceNotFoundException:
Resource not found.: org.apache.excalibur.source.SourceNotFoundException: Resource not found
file:/old/home/jeff/homeoverflow/apache/xml/xml-forrest/build/bot/projects/myproj-local/context/./content/xdocs/your-project.xml
> 
> Which is bizarre, since your-project.xml certainly isn't mentioned anywhere in
> my test project. However, running just './build.sh bot' worked fine, so I'm
> sure it's something minor.

It sounds like some separate issues. Your ForrestBot is
building the main Forrest project doco here.

When you copied the forrestbot.conf.xml to testproj.conf.xml
did you remove the old <project>+ entries and put your own?

Another possibility - if /home/jeff/testproj/testproj.conf.xml
path is wrong, then it will use $FORREST_HOME/forrestbot.conf.xml
and build the main project doco.

Aha. I just noticed something that may be the cause.
If you do not do a 'build clean' before running forrestbot
then it just re-runs the previous build. So if you had
done a plain './build.sh bot' then forrestbot would try to
build the default Forrest doco. If you immediately follow
that with building your own project:
 ./build.sh bot -Dbot.forrestbot.xconf=$HOME/yourproject.conf.xml
then forrestbot does not build your project but repeats the
default build.

Also, it seems that your xml-forrest CVS is not up-to-date.
The doc your-project.html is certainly linked from changes.html
and it should be there at xdocs/your-project.xml
Does the normal "./build.sh clean docs" work for you?
--David




Mime
View raw message