forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piroumian Konstantin <KPiroum...@protek.com>
Subject RE: [VOTE] Konstantin Piroumian as new Forrest committer
Date Tue, 21 May 2002 13:03:23 GMT
> From: Steven Noels [mailto:stevenn@outerthought.org] 
> 
> I used WinCVS and putty/plink (password based auth) prior to switching
> to CygWin - that worked, too.

Password based authentication works for me too. But it's rather boring to
enter the password for every command. (Though, it adds another possibility
to think before committing anything ;))

> 
> Why do you want to use the "-1" option? Don't need to specify that one
> over here...

For whatever reason SSH2 does not work for me here. -1 forces to use SSH1
and it works. 

> 
> my env settings in cygwin:
> 
> CVSROOT=:ext:stevenn@cvs.apache.org:/home/cvs
> CVS_RSH=ssh

Mine's are similar. The problem is some other place. There is no a
kpiroumian user in /etc/passwd (as I am a domain user) and the result is
that CygWin uses /home/Administrator to store my ssh keys. But the real user
is not the Administrator, but KPiroumian.

I'm sure that from home I'll setup everything with no problems. As soon as I
succeed with it I'll right the HowTo doc and will try to solve the problem
here. 
It can be also that my HOME variable is set to a network drive (corporate
politics) and the SSH doesn't use keys if Home directory has read
permissions for any other user except the current one. In my case Domain
Administrators also have access to it.

> 
> I'm no Cygwin expert, John helped me through this.

I've asked several Unix/CygWin experts, but nobody was able to solve the
problem. Will be trying again.

Konstantin

> 
> </Steven>
> 

Mime
View raw message