forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicola Ken Barozzi" <baro...@nicolaken.com>
Subject Re: Krysalis Centipede 0.2 ready
Date Mon, 25 Feb 2002 17:35:30 GMT

----- Original Message -----
From: "Ugo Cei" <u.cei@cbim.it>
To: <forrest-dev@xml.apache.org>
Sent: Monday, February 25, 2002 6:09 PM
Subject: Re: Krysalis Centipede 0.2 ready


> Nicola Ken Barozzi wrote:
>
> > This problem comes from the fact that all jars in ./tools/centipede/lib/
> > must be in the classpath.
> > Usually they are placed in ant/lib and that's all, but to make ant
upgrade
> > easier, I put them in another dir.
> >
> > build.bat puts these jars in the classpath, and it works.
> > I tried to do the same with build.sh, and it works on my machine, but
mind
> > me, I have W200 and cygwin, and don't know if paths are treated
consistently
> > with Linux in Cygwin.
>
> Paths in Unix use a colon as separator, not a semicolon. Change the line
> that sets the CLASSPATH to:
>
>
CLASSPATH="./tools/centipede/lib/xml-apis.jar:./tools/centipede/lib/xerces.j
ar:./tools/centipede/lib/xalan.jar:./tools/centipede/lib/junit.jar:./tools/c
entipede/lib/jIzPress.jar:./tools/centipede/lib/jtidy.jar"
>
> It compiles now.

:-) Thanks.

Gee, I thought I put commas there, AFAIK they should work too, but
semicolons got in.

Thank you very much, patch applied to CVS :-)

--
Nicola Ken Barozzi                 barozzi@nicolaken.com
            - verba volant, scripta manent -
   (discussions get forgotten, just code remains)
---------------------------------------------------------------------


Mime
View raw message