flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zaenal rifai <togatta.f...@gmail.com>
Subject Re: Flume HTTP source failed
Date Mon, 28 Dec 2015 07:38:02 GMT
thanks gonzalo, the problem is on my side. On my workplace, the team
developer has made some modification on lib http-source.

and can i ask some more question again ? i had a problem again when using
failover method, which is said "ERROR lifecycle.LifecycleSupervisor: Unable
to start EventDrivenSourceRunner:"

http://tempel.blankon.in/1647617e

On 21 December 2015 at 15:15, Gonzalo Herreros <gherreros@gmail.com> wrote:

> Seems pretty obvious to me. You are using a class that doesn't exist
>
> httpagent1.sources.http-source.type = org.apache.flume.source.http.testHTTPSource
>
>
> You should use:
>
> httpagent1.sources.http-source.type = org.apache.flume.source.http.HTTPSource
>
>
> which can be shortcutted to just "http"
>
>
> You'll also have a problem with org.apache.flume.source.http.testHandler
>
>
> if you intend to use a custom class then you need to install the jar in the plugin directory
>
>
> Regards,
>
> Gonzalo
>
>
> On 21 December 2015 at 07:24, zaenal rifai <togatta.fudo@gmail.com> wrote:
>
>> Hi all,
>>
>> i make some topology flume which collect data from nginx and write to
>> hdfs...
>>
>> first is top agent ---> mid agent ---> hdfs agent
>>
>> top agent = http source which collect data from nginx
>> mid agent = which will forward the source to hdfs agent
>> hdfs agent = which will write the data to hdfs
>>
>> but when i'll run the top agent, there is some problem
>>
>> http://tempel.blankon.in/1628710
>>
>> and this is my conf top agent
>>
>> http://tempel.blankon.in/1628711
>>
>>
>

Mime
View raw message