flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gonzalo Herreros <gherre...@gmail.com>
Subject Re: Help! Apache Flume 1.6 Intermittently fails to function
Date Fri, 20 Nov 2015 23:00:01 GMT
When it fails you are running it from the conf directory so it doesn't find
the --conf conf
In the second case you run it from the flume home dir

Regards,
Gonzalo

On 20 November 2015 at 22:23, Minnie Haridasa (mharidas) <mharidas@cisco.com
> wrote:

> Hi,
>
>
> I am using Apache Flume 1.6 and using a simple memory channel to connect
> syslog to logger.
> Flume intermittently fails to start..
>
> When it fails …
> [root@si-mtv5-log-01:/usr/local/apache-flume-1.6.0-bin/conf]# flume-ng
> agent --conf conf --conf-file $FLUME_HOME/conf/flume-syslog.conf -name a1
> -D-d flume.root.logger=DEBUG,console
> Warning: JAVA_HOME is not set!
> Info: Including Hive libraries found via () for Hive access
> + exec /usr/bin/java -Xmx20m -D-d -cp
> 'conf:/usr/local/apache-flume-1.6.0-bin/lib/*:/lib/*' -Djava.library.path=
> org.apache.flume.node.Application --conf-file
> /usr/local/apache-flume-1.6.0-bin/conf/flume-syslog.conf -name a1
> flume.root.logger=DEBUG,console
> log4j:WARN No appenders could be found for logger
> (org.apache.flume.lifecycle.LifecycleSupervisor).
> log4j:WARN Please initialize the log4j system properly.
> log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
> more info.
>
>
> When it starts..
> [root@si-mtv5-log-01:/usr/local/apache-flume-1.6.0-bin]# flume-ng agent
> --conf conf --conf-file $FLUME_HOME/conf/flume-syslog.conf -name a1
> -Dflume.root.logger=DEBUG,console
> Info: Sourcing environment configuration script
> /usr/local/apache-flume-1.6.0-bin/conf/flume-env.sh
> Warning: JAVA_HOME is not set!
> Info: Including Hive libraries found via () for Hive access
> + exec /usr/bin/java -Xmx20m -Dflume.root.logger=DEBUG,console -cp
> '/usr/local/apache-flume-1.6.0-bin/conf:/usr/local/apache-flume-1.6.0-bin/lib/*:/lib/*'
> -Djava.library.path= org.apache.flume.node.Application --conf-file
> /usr/local/apache-flume-1.6.0-bin/conf/flume-syslog.conf -name a1
> 2015-11-19 12:00:34,220 (lifecycleSupervisor-1-0) [INFO -
> org.apache.flume.node.PollingPropertiesFileConfigurationProvider.start(PollingPropertiesFileConfigurationProvider.java:61)]
> Configuration provider starting
> 2015-11-19 12:00:34,224 (lifecycleSupervisor-1-0) [DEBUG -
> org.apache.flume.node.PollingPropertiesFileConfigurationProvider.start(PollingPropertiesFileConfigurationProvider.java:78)]
> Configuration provider started
> 2015-11-19 12:00:34,226 (conf-file-poller-0) [DEBUG -
> org.apache.flume.node.PollingPropertiesFileConfigurationProvider$FileWatcherRunnable.run(PollingPropertiesFileConfigurationProvider.java:126)]
> Checking file:/usr/local/apache-flume-1.6.0-bin/conf/flume-syslog.conf for
> changes
>
>
> Why this discrepancy?
> In both cases I am able to telnet the port 7077 but when it fails to start
> I can telnet but nothing echos back
>
>
>
> Your help is appreciated.
> Thanks
> Minnie
>

Mime
View raw message