flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From terreyshih <terreys...@gmail.com>
Subject Re: The znode for the -ROOT- region doesn't exist! ERROR
Date Thu, 14 Aug 2014 10:21:53 GMT
Hi,

Actually, the interesting thing is that if I have HBase installed locally on the same flume
server machine but have a hbase-site.xml connecting to a remote hbase server, the connection
is fine.

It seems that if I don’t have a local HBase installation, I get this error.

Am I missing something here ?

thanks,
-Gary

On Aug 13, 2014, at 5:15 PM, terreyshih <terreyshih@gmail.com> wrote:

> Thanks Natty.  Yes, Hari.  I am using flume 1.5.  I will double check the configuration
again just to make sure.
> 
> thanks
> On Aug 13, 2014, at 4:56 PM, Hari Shreedharan <hshreedharan@cloudera.com> wrote:
> 
>> Actually what version of Flume are you using? ROOT was removed in Hbase 96 I think,
you need to use Flume 1.5.0 or higher for asynchbase sink to work.
>> 
>> 
>> On Wed, Aug 13, 2014 at 4:51 PM, Jonathan Natkins <natty@streamsets.com> wrote:
>> Hey Gary,
>> 
>> From the information I've got here, this looks like more of an HBase problem than
a Flume problem. My recommendation would be to first double check that you can run commands
against the HBase instance from your Flume agent node. Try running `hbase shell` and execute
a list command. If you get complaints, that's probably where your problem is originating from.
>> 
>> Otherwise, it may be that there is an issue with your HBase configuration on your
Flume agent node. You might not be pointing at the correct ZooKeeper quorum, or something
along those lines.
>> 
>> Thanks,
>> Natty
>> 
>> 
>> 
>> On Wed, Aug 13, 2014 at 3:53 PM, terrey shih <terreyshih@gmail.com> wrote:
>> Hi,
>> 
>> I have the flume setup using asynchbase sink to write to Hbase server locally and
everything works fine on my local machine.
>> 
>> However when I configured it to connect to a remote hadoop server using the hbase-site.xml.
I got the following error.
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> ERROR [main-EventThread] (HBaseClient.java:2860)
>> > > - The znode for the -ROOT- region doesn't exist!
>> 
>> 
>> I did google on this and it seems like it has something to do with the asynchbase
needs to be compatible with 0.96 version of habase (which is the version I am using).
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> Does that mean I need recompile the whole flume asynchbase source with the jar files
from 0.96 version of the hbase distribution ?
>> 
>> Can anybody share some light no this ?
>> 
>> thanks,
>> 
>> -Gary
>> 
>> 
>> 
> 


Mime
View raw message