flume-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vegiapparao <...@git.apache.org>
Subject [GitHub] flume pull request #185: Feature/kafka 2.12 1.0.0
Date Tue, 28 Nov 2017 11:24:29 GMT
GitHub user vegiapparao opened a pull request:

    https://github.com/apache/flume/pull/185

    Feature/kafka 2.12 1.0.0

    This PR has the changes to get Apache Flume working with the latest version if Kafka client.
 We had issues getting one of the authentication types working with older version of Kafka
client.  Its working with Kafka_2.12_1.0.0.
    
    Few tests are failing (most of the times they are related to VM crash/time out)  in flume-kafka-channel
project, I will be fixing them, but I am creating this PR for an early feedback.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/vegiapparao/flume feature/kafka_2.12_1.0.0

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/flume/pull/185.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #185
    
----
commit b4cdefb89c79dca976ea7fb5468fef867f12960a
Author: Apparao Vegi <apparao_vegi@bnz.co.nz>
Date:   2017-11-28T10:45:26Z

    Changes made to get Apache Flume working with the latest version of kafka client 2_12.1.0.0

commit 616792bd3611ee9d7d36e18ee81c9e83c0859fda
Author: Apparao Vegi <apparao_vegi@bnz.co.nz>
Date:   2017-11-28T11:13:02Z

    Fixed checkstyle errors

----


---

Mime
View raw message