flume-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLUME-3132) Upgrade tomcat jasper library dependencies
Date Tue, 15 Aug 2017 07:24:00 GMT

    [ https://issues.apache.org/jira/browse/FLUME-3132?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16126884#comment-16126884
] 

ASF GitHub Bot commented on FLUME-3132:
---------------------------------------

GitHub user szaboferee opened a pull request:

    https://github.com/apache/flume/pull/152

    FLUME-3132 Upgrade tomcat jasper library dependencies

    excluding vulnerable dependencies

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/szaboferee/flume FLUME-3132

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/flume/pull/152.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #152
    
----
commit ed60c294005ba1bb46b86d8f62ddc0d655efca3b
Author: Ferenc Szabo <fszabo@cloudera.com>
Date:   2017-08-14T16:34:33Z

    FLUME-3132 Upgrade tomcat jasper library dependencies
    
    excluding vulnerable dependencies

----


> Upgrade tomcat jasper library dependencies
> ------------------------------------------
>
>                 Key: FLUME-3132
>                 URL: https://issues.apache.org/jira/browse/FLUME-3132
>             Project: Flume
>          Issue Type: Bug
>    Affects Versions: 1.7.0
>            Reporter: Attila Simon
>            Assignee: Ferenc Szabo
>            Priority: Critical
>              Labels: dependency
>             Fix For: 1.8.0
>
>
> ||Group||Artifact||Version used||Upgrade target||
> |tomcat|jasper-compiler|5.5.23|8.5.x|
> |tomcat|jasper-runtime|5.5.23|8.5.x|
> Security vulnerability: 
> - https://www.cvedetails.com/cve/CVE-2011-1318/
> - http://www.cvedetails.com/vulnerability-list/vendor_id-45/product_id-887/Apache-Tomcat.html
> Maven repositories: 
> - https://mvnrepository.com/artifact/org.apache.tomcat/tomcat-jasper
> Note: These artifacts were moved to:
> * New Group	org.apache.tomcat
> * New Artifact	
> Please do:
> - CVE might be a false alarm or mistake. Please double check.
> - double check the newest version. 
> - consider to remove a dependency if better alternative is available.
> - check whether the lib change would introduce a backward incompatibility (in which case
please add this label `breaking_change` and fix version should be the next major)
> Excerpt from mvn dependency:tree
> {noformat}
> org.apache.flume:flume-ng-auth:jar:1.8.0-SNAPSHOT
> +- org.apache.hadoop:hadoop-common:jar:2.4.0:compile
> |  +- tomcat:jasper-compiler:jar:5.5.23:runtime
> |  +- tomcat:jasper-runtime:jar:5.5.23:runtime
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message