flume-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Attila Simon (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLUME-3125) Upgrade fontbox library dependency
Date Wed, 19 Jul 2017 13:40:00 GMT
Attila Simon created FLUME-3125:
-----------------------------------

             Summary: Upgrade fontbox library dependency
                 Key: FLUME-3125
                 URL: https://issues.apache.org/jira/browse/FLUME-3125
             Project: Flume
          Issue Type: Bug
    Affects Versions: 1.7.0
            Reporter: Attila Simon
            Priority: Critical
             Fix For: 1.8.0


||Group||Artifact||Version used||Upgrade target||
|org.apache.pdfbox|fontbox|1.8.4|2.0.6|

Security vulnerability: http://www.cvedetails.com/cve/CVE-2016-2175/
Maven repository: https://mvnrepository.com/artifact/org.apache.pdfbox/fontbox

Please do:
- CVE might be a false alarm or mistake. Please double check.
- double check the newest version. 
- consider to remove a dependency if better alternative is available.
- check whether the lib change would introduce a backward incompatibility (in which case please
add this label `breaking_change` and fix version should be the next major)

Excerpt from mvn dependency:tree
{noformat}
org.apache.flume.flume-ng-sinks:flume-ng-morphline-solr-sink:jar:1.8.0-SNAPSHOT
+- org.kitesdk:kite-morphlines-all:pom:1.0.0:compile
|  +- org.kitesdk:kite-morphlines-solr-cell:jar:1.0.0:compile
|  |  +- org.apache.tika:tika-xmp:jar:1.5:compile
|  |  |  +- org.apache.tika:tika-parsers:jar:1.5:compile
|  |  |  |  +- org.apache.pdfbox:pdfbox:jar:1.8.4:compile
|  |  |  |  |  +- org.apache.pdfbox:fontbox:jar:1.8.4:compile
{noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message