flume-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pravin Dsilva (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLUME-3057) Build fails due to unsupported snappy-java version on ppc64le
Date Wed, 22 Feb 2017 07:04:44 GMT

     [ https://issues.apache.org/jira/browse/FLUME-3057?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pravin Dsilva updated FLUME-3057:
---------------------------------
    Attachment: FLUME-3057.patch

> Build fails due to unsupported snappy-java version on ppc64le
> -------------------------------------------------------------
>
>                 Key: FLUME-3057
>                 URL: https://issues.apache.org/jira/browse/FLUME-3057
>             Project: Flume
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: v1.8.0
>         Environment: $ uname -a
> Linux 2f63413ff231 4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:05:18 UTC 2016 ppc64le
ppc64le ppc64le GNU/Linux
>            Reporter: Pravin Dsilva
>              Labels: powerpc, ppc64le
>         Attachments: FLUME-3057.patch
>
>
> Flume has a snappy-java dependency with version 1.1.0. Upon building Flume on ppc64le
architecture, errors such as "[FAILED_TO_LOAD_NATIVE_LIBRARY] no native library is found for
os.name=Linux and os.arch=ppc64le" are seen
>  Native libraries for ppc64le were added in version in snappy-java version 1.1.1. Hence
Flume needs to have this higher version of snappy-java.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message