flume-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lior Zeno (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLUME-2945) Bump java target version to 1.8
Date Sat, 15 Oct 2016 16:04:20 GMT

     [ https://issues.apache.org/jira/browse/FLUME-2945?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lior Zeno updated FLUME-2945:
-----------------------------
    Description: 
We should move to Java 8 as a minimum requirement.

# Java 7 is EOL'ed http://www.oracle.com/technetwork/java/eol-135779.html.
# Many projects are adopting java 8 as a minimum requirement, for instance:
* Solr 6: https://issues.apache.org/jira/browse/LUCENE-6722
* Hbase 2: https://issues.apache.org/jira/browse/HBASE-15624
* elasticsearch 5: https://www.elastic.co/guide/en/elasticsearch/reference/master/setup.html

The attached patch was tested on Ubuntu 16.04 with openjdk version "1.8.0_91".
All unit tests, except for the known flaky ones, successfully passed.


  was:
We should move to Java 8 as a minimum requirement.

# Java 7 is EOL'ed http://www.oracle.com/technetwork/java/eol-135779.html.
# Many projects are adopting java 8 as a minimum requirement, for instance:
* Solr 6: https://issues.apache.org/jira/browse/LUCENE-6722
* Hbase 2: https://issues.apache.org/jira/browse/HBASE-15624
* elasticsearch 5: https://www.elastic.co/guide/en/elasticsearch/reference/master/setup.html


> Bump java target version to 1.8
> -------------------------------
>
>                 Key: FLUME-2945
>                 URL: https://issues.apache.org/jira/browse/FLUME-2945
>             Project: Flume
>          Issue Type: Improvement
>    Affects Versions: v1.8.0
>            Reporter: Lior Zeno
>            Assignee: Lior Zeno
>             Fix For: v1.8.0
>
>         Attachments: FLUME-2945-0.patch
>
>
> We should move to Java 8 as a minimum requirement.
> # Java 7 is EOL'ed http://www.oracle.com/technetwork/java/eol-135779.html.
> # Many projects are adopting java 8 as a minimum requirement, for instance:
> * Solr 6: https://issues.apache.org/jira/browse/LUCENE-6722
> * Hbase 2: https://issues.apache.org/jira/browse/HBASE-15624
> * elasticsearch 5: https://www.elastic.co/guide/en/elasticsearch/reference/master/setup.html
> The attached patch was tested on Ubuntu 16.04 with openjdk version "1.8.0_91".
> All unit tests, except for the known flaky ones, successfully passed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message