flume-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From br...@apache.org
Subject git commit: FLUME-1696: Update build instructions as Flume build requires more memory
Date Mon, 12 Nov 2012 17:41:25 GMT
Updated Branches:
  refs/heads/flume-1.3.0 08cae54b1 -> d01480fd4


FLUME-1696: Update build instructions as Flume build requires more memory

(Brock Noland via Brock Noland)


Project: http://git-wip-us.apache.org/repos/asf/flume/repo
Commit: http://git-wip-us.apache.org/repos/asf/flume/commit/d01480fd
Tree: http://git-wip-us.apache.org/repos/asf/flume/tree/d01480fd
Diff: http://git-wip-us.apache.org/repos/asf/flume/diff/d01480fd

Branch: refs/heads/flume-1.3.0
Commit: d01480fd4c1b350ac26c756019172c34aacdb0f0
Parents: 08cae54
Author: Brock Noland <brock@apache.org>
Authored: Mon Nov 12 11:37:58 2012 -0600
Committer: Brock Noland <brock@apache.org>
Committed: Mon Nov 12 11:38:13 2012 -0600

----------------------------------------------------------------------
 README |    5 +++++
 1 files changed, 5 insertions(+), 0 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flume/blob/d01480fd/README
----------------------------------------------------------------------
diff --git a/README b/README
index c4063f4..23150d3 100644
--- a/README
+++ b/README
@@ -39,6 +39,11 @@ Compiling Flume requires the following tools:
 * Oracle Java JDK 1.6
 * Apache Maven 3.x
 
+Note: The Apache Flume build requires more memory than the default configuration.
+We recommend you set the following Maven options:
+
+export MAVEN_OPTS="-Xms512m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m
+
 To compile Flume, run `mvn compile`.
 To build a distribution, run `mvn install`.
 


Mime
View raw message