flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OpenInx <open...@gmail.com>
Subject Re: [DISCUSS] Upgrade HBase connector to 2.2.x
Date Mon, 22 Jun 2020 02:04:46 GMT
Hi

According to my observation in the hbase community, there are still lots of
hbase users running their production cluster with version 1.x (1.4x or
1.5.x). so I'd like to suggest that
supporting both hbase1.x & hbase2.x connector.

Thanks.

On Sat, Jun 20, 2020 at 2:41 PM Ming Li <brighty916@gmail.com> wrote:

> +1 to support both HBase 2.x and Hbase 1.4.x,  just as what we are doing
> for Kafka.
>
> On Fri, Jun 19, 2020 at 4:02 PM Yu Li <carp84@gmail.com> wrote:
>
>> One supplement:
>>
>> I noticed that there are discussions in HBase ML this March about
>> removing stable-1 pointer and got consensus [1], and will follow up in
>> HBase community about why we didn't take real action. However, this doesn't
>> change my previous statement / stand due to the number of 1.x usages in
>> production.
>>
>> Best Regards,
>> Yu
>>
>> [1]
>> http://mail-archives.apache.org/mod_mbox/hbase-dev/202003.mbox/%3C30180be2-bd93-d414-a158-16c9c8d010f3@apache.org%3E
>>
>> On Fri, 19 Jun 2020 at 15:54, Yu Li <carp84@gmail.com> wrote:
>>
>>> +1 on upgrading the HBase version of the connector, and 1.4.3 is indeed
>>> an old version.
>>>
>>> OTOH, AFAIK there're still quite some 1.x HBase clusters in production.
>>> We could also see that the HBase community is still maintaining 1.x release
>>> lines (with "stable-1 release" point to 1.4.13) [1]
>>>
>>> Please also notice that HBase follows semantic versioning [2] [3] thus
>>> don't promise any kind of compatibility (source/binary/wire, etc.) between
>>> major versions. So if we only maintain 2.x connector, it would not be able
>>> to work with 1.x HBase clusters.
>>>
>>> I totally understand the additional efforts of maintaining two modules,
>>> but since we're also reserving multiple versions for kafka connector,
>>> meantime considering the current HBase in-production status, I'd still
>>> suggest to get both 1.4.13 and 2.2.5 supported.
>>>
>>> Best Regards,
>>> Yu
>>>
>>> [1] http://hbase.apache.org/downloads.html
>>> [2] https://hbase.apache.org/book.html#hbase.versioning
>>> [3] https://semver.org/
>>>
>>>
>>> On Fri, 19 Jun 2020 at 14:58, Leonard Xu <xbjtdcq@gmail.com> wrote:
>>>
>>>> +1 to support HBase 2.2.x, and +1 to retain HBase 1.4.3 until we
>>>> deprecates finished(maybe one version is enough).
>>>>
>>>> Currently we only support HBase 1.4.3 which is pretty old, and I’m
>>>> making a flink-sql-connector-hbase[1] shaded jar for pure SQL user, the
>>>> dependencies is a little more complex.
>>>>
>>>>
>>>> 在 2020年6月19日,14:20,jackylau <liuyongvs@gmail.com> 写道:
>>>>
>>>> + 1 to support HBase 2.x and the hbase 2.x client dependencies are
>>>> simple and clear. Tbe hbase project shades them all
>>>>
>>>>
>>>> Best,
>>>> Leonard Xu
>>>> [1] https://github.com/apache/flink/pull/12687
>>>>
>>>>
>
> --
> Best Regards
> Michael Li
>

Mime
View raw message