flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Borgschulze" <borg...@web.de>
Subject Can I use Apache-Flink for Android API-Level < 26?
Date Tue, 14 Apr 2020 09:03:53 GMT
<html><head></head><body><div style="font-family: Verdana;font-size:
12.0px;"><div>I am trying to use Apache-Flink in my Android-Project with &quot;minSdkVersion
24&quot;.</div>

<div>Unfortunately, the following code causes an error:</div>

<div>&nbsp; &nbsp;</div>

<div>&nbsp;</div>

<div>&nbsp; &nbsp; val env: StreamExecutionEnvironment = LocalStreamEnvironment.getExecutionEnvironment()<br/>
&nbsp; &nbsp; env.streamTimeCharacteristic = TimeCharacteristic.ProcessingTime<br/>
&nbsp; &nbsp; val integerStream: DataStream&lt;Int&gt; = env.fromCollection(mutableListOf(1,2,3,4,5))<br/>
&nbsp; &nbsp;&nbsp;<br/>
&nbsp; &nbsp; integerStream.print()<br/>
&nbsp; &nbsp; env.execute()</div>

<div><br/>
&nbsp;</div>

<div>java.lang.NoClassDefFoundError: Failed resolution of: Ljava/time/Instant;<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.api.common.typeinfo.BasicTypeInfo.&lt;clinit&gt;(BasicTypeInfo.java:89)<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.api.common.typeinfo.BasicTypeInfo.getInfoFor(BasicTypeInfo.java:214)<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.api.java.typeutils.TypeExtractor.privateGetForClass(TypeExtractor.java:1705)<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.api.java.typeutils.TypeExtractor.privateGetForClass(TypeExtractor.java:1643)<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.api.java.typeutils.TypeExtractor.privateGetForObject(TypeExtractor.java:2038)<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.api.java.typeutils.TypeExtractor.getForObject(TypeExtractor.java:1983)<br/>
&nbsp; &nbsp; &nbsp; &nbsp; at org.apache.flink.streaming.api.environment.StreamExecutionEnvironment.fromCollection(StreamExecutionEnvironment.java:782)</div>

<div>&nbsp;</div>

<div>&nbsp;</div>

<div>&nbsp;</div>

<div>The java.time API was introduced in API Level 26. So is it impossible to run Flink
on older Android-Verions?</div></div></body></html>

Mime
View raw message