Hi Chad,
Beam Portability module solves the management of the Python runtime environment and the communication between the Python runtime environment Python VM and the Java runtime environment JVM in PyFlink. For details, you can refer to FLIP-58[1] and the Blog[2]. 

Hope to resolve your doubts.

Best,
Xingbo

[1] https://cwiki.apache.org/confluence/display/FLINK/FLIP-58%3A+Flink+Python+User-Defined+Stateless+Function+for+Table
[2] https://enjoyment.cool/2020/02/19/Deep-dive-how-to-support-Python-UDF-in-Apache-Flink-1-10/

Chad Dombrova <chadrik@gmail.com> 于2020年2月21日周五 上午12:16写道:
Hi,
Very cool. I’m curious about the relationship between this feature and Apache Beam.  What parts of Beam are used and for what?  Does this have any impact on existing Beam users like myself who use the Beam python API on top of Flink?  Can someone give me a brief overview or point me at the right documentation?

Thanks!
-chad


On Thu, Feb 20, 2020 at 5:39 AM Xingbo Huang <hxbks2ks@gmail.com> wrote:
Thanks a lot for the release.
Great Work, Jincheng!
Also thanks to participants who contribute to this release.

Best,
Xingbo


Till Rohrmann <trohrmann@apache.org> 于2020年2月18日周二 下午11:40写道:
Thanks for updating the 1.9.2 release wrt Flink's Python API Jincheng!

Cheers,
Till

On Thu, Feb 13, 2020 at 12:25 PM Hequn Cheng <hequn@apache.org> wrote:
Thanks a lot for the release, Jincheng!
Also thanks to everyone that make this release possible!

Best,
Hequn

On Thu, Feb 13, 2020 at 2:18 PM Dian Fu <dian0511.fu@gmail.com> wrote:

> Thanks for the great work, Jincheng.
>
> Regards,
> Dian
>
> 在 2020年2月13日,下午1:32,jincheng sun <sunjincheng121@gmail.com> 写道:
>
> Hi everyone,
>
> The Apache Flink community is very happy to announce the release of Apache
> Flink Python API(PyFlink) 1.9.2, which is the first release to PyPI for the
> Apache Flink Python API 1.9 series.
>
> Apache Flink® is an open-source stream processing framework for
> distributed, high-performing, always-available, and accurate data streaming
> applications.
>
> The release is available for download at:
>
> https://pypi.org/project/apache-flink/1.9.2/#files
>
> Or installed using pip command:
>
> pip install apache-flink==1.9.2
>
> We would like to thank all contributors of the Apache Flink community who
> helped to verify this release and made this release possible!
>
> Best,
> Jincheng
>
>
>