flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ufuk Celebi <...@apache.org>
Subject Re: [DISCUSS] Drop Savepoint Compatibility with Flink 1.2
Date Sat, 22 Feb 2020 14:05:07 GMT
Hey Stephan,

+1.

Reading over the linked ticket and your description here, I think it makes
a lot of sense to go ahead with this. Since it's possible to upgrade via
intermediate Flink releases as a fail-safe I don't have any concerns.

– Ufuk


On Fri, Feb 21, 2020 at 4:34 PM Till Rohrmann <trohrmann@apache.org> wrote:
>
> +1 for dropping savepoint compatibility with Flink 1.2.
>
> Cheers,
> Till
>
> On Thu, Feb 20, 2020 at 6:55 PM Stephan Ewen <sewen@apache.org> wrote:
>>
>> Thank you for the feedback.
>>
>> Here is the JIRA issue with some more explanation also about the
background and implications:
>> https://jira.apache.org/jira/browse/FLINK-16192
>>
>> Best,
>> Stephan
>>
>>
>> On Thu, Feb 20, 2020 at 2:26 PM vino yang <yanghua1127@gmail.com> wrote:
>>>
>>> +1 for dropping Savepoint compatibility with Flink 1.2
>>>
>>> Flink 1.2 is quite far away from the latest 1.10. Especially after the
release of Flink 1.9 and 1.10, the code and architecture have undergone
major changes.
>>>
>>> Currently, I am updating state migration tests for Flink 1.10. I can
still see some binary snapshot files of version 1.2. If we agree on this
topic, we may be able to alleviate some of the burdens(remove those binary
files) when the migration tests would be updated later.
>>>
>>> Best,
>>> Vino
>>>
>>> Theo Diefenthal <theo.diefenthal@scoop-software.de> 于2020年2月20日周四
下午9:04写道:
>>>>
>>>> +1 for dropping compatibility.
>>>>
>>>> I personally think that it is very important for a project to keep a
good pace in developing that old legacy stuff must be dropped from time to
time. As long as there is an upgrade routine (via going to another flink
release) that's fine.
>>>>
>>>> ________________________________
>>>> Von: "Stephan Ewen" <sewen@apache.org>
>>>> An: "dev" <dev@flink.apache.org>, "user" <user@flink.apache.org>
>>>> Gesendet: Donnerstag, 20. Februar 2020 11:11:43
>>>> Betreff: [DISCUSS] Drop Savepoint Compatibility with Flink 1.2
>>>>
>>>> Hi all!
>>>> For some cleanup and simplifications, it would be helpful to drop
Savepoint compatibility with Flink version 1.2. That version was released
almost three years ago.
>>>>
>>>> I would expect that no one uses that old version any more in a way
that they actively want to upgrade directly to 1.11.
>>>>
>>>> Even if, there is still the way to first upgrade to another version
(like 1.9) and then upgrade to 1.11 from there.
>>>>
>>>> Any concerns to drop that support?
>>>>
>>>> Best,
>>>> Stephan
>>>>
>>>>
>>>> --
>>>> SCOOP Software GmbH - Gut Maarhausen - Eiler Straße 3 P - D-51107 Köln
>>>> Theo Diefenthal
>>>>
>>>> T +49 221 801916-196 - F +49 221 801916-17 - M +49 160 90506575
>>>> theo.diefenthal@scoop-software.de - www.scoop-software.de
>>>> Sitz der Gesellschaft: Köln, Handelsregister: Köln,
>>>> Handelsregisternummer: HRB 36625
>>>> Geschäftsführung: Dr. Oleg Balovnev, Frank Heinen,
>>>> Martin Müller-Rohde, Dr. Wolfgang Reddig, Roland Scheel

>

Mime
View raw message