flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jatin Banger <bangerjatinrm...@gmail.com>
Subject Re: Flink 'Job Cluster' mode Ui Access
Date Tue, 10 Dec 2019 17:07:28 GMT
Yes, I did.

On Tue, Dec 10, 2019 at 3:47 PM Arvid Heise <arvid@ververica.com> wrote:

> Hi Jatin,
>
> just to be sure. Did you increase the log level to debug [1] before
> checking for *StaticFileServerHandler*?
>
> Best,
>
> Arvid
>
> [1]
> https://ci.apache.org/projects/flink/flink-docs-stable/monitoring/logging.html#configuring-log4j
>
> On Mon, Dec 9, 2019 at 7:54 AM Jatin Banger <bangerjatinrmrvf@gmail.com>
> wrote:
>
>> Hi,
>>
>> I have checked the logs with this keyword  *StaticFileServerHandler   *in
>> it, But there were no logs coming for "Flink Job Cluster".
>> Then i checked for Flink Session Cluster, i was able to find the logs for
>> the *StaticFileServerHandler *keyword.
>>
>> Can i raise this as bug ?
>>
>> Best Regards,
>> Jatin
>>
>>
>> On Thu, Dec 5, 2019 at 8:59 PM Chesnay Schepler <chesnay@apache.org>
>> wrote:
>>
>>> Ok, it's good to know that the WebUI files are there.
>>>
>>> Please enable DEBUG logging and try again, searching for messages from
>>> the StaticFileServerHandler.
>>>
>>> This handler logs every file that is requested (which effectively
>>> happens when the WebUI is being served); let's see what is actually being
>>> requested.
>>>
>>> On 05/12/2019 05:57, Jatin Banger wrote:
>>>
>>> I have tried that already using
>>> '$FLINK_HOME/bin/jobmanager.sh" start-foreground
>>> Ui comes fine with this one.
>>> Which means web/index.html is present.
>>>
>>>
>>> On Wed, Dec 4, 2019 at 9:01 PM Chesnay Schepler <chesnay@apache.org>
>>> wrote:
>>>
>>>> hmm...this is quite odd.
>>>>
>>>> Let's try to narrow things down a bit.
>>>>
>>>> Could you try starting a local cluster (using the same distribution)
>>>> and checking whether the UI is accessible?
>>>>
>>>> Could you also check whether the flink-dist.jar in /lib contains
>>>> web/index.html?
>>>> On 04/12/2019 06:02, Jatin Banger wrote:
>>>>
>>>> Hi,
>>>>
>>>> I am using flink binary directly.
>>>>
>>>> I am using this command to deploy the script.
>>>>
>>>>                         "$FLINK_HOME/bin/standalone-job.sh"
>>>> start-foreground --job-classname ${ARGS_FOR_JOB}
>>>> where ARGS_FOR_JOB contain job class name and all other necessary
>>>> details needed by the job.
>>>>
>>>> Best regards,
>>>> Jatin
>>>>
>>>>
>>>> On Fri, Nov 29, 2019 at 4:18 PM Chesnay Schepler <chesnay@apache.org>
>>>> wrote:
>>>>
>>>>> To clarify, you ran "mvn package -pl flink-dist -am" to build Fink?
>>>>>
>>>>> If so, could you run that again and provide us with the maven output?
>>>>>
>>>>> On 29/11/2019 11:23, Jatin Banger wrote:
>>>>>
>>>>> Hi,
>>>>>
>>>>> @vino yang <yanghua1127@gmail.com>  I am using flink 1.8.1
>>>>>
>>>>> I am using the following procedure for the deployment:
>>>>>
>>>>> https://github.com/apache/flink/blob/master/flink-container/docker/README.md
>>>>>
>>>>> And i tried accessing the path you mentioned:
>>>>>
>>>>> # curl <pod-Ip>:4081/#/overview
>>>>> {"errors":["Not found."]}
>>>>>
>>>>> Best Regards,
>>>>> Jatin
>>>>>
>>>>> On Thu, Nov 28, 2019 at 10:21 PM Chesnay Schepler <chesnay@apache.org>
>>>>> wrote:
>>>>>
>>>>>> Could you try accessing <pid-Ip>:/#/overview ?
>>>>>>
>>>>>> The REST API is obviously accessible, and hence the WebUI should
be
>>>>>> too.
>>>>>>
>>>>>> How did you setup the session cluster? Are you using some custom
>>>>>> Flink build or something, which potentially excluded flink-runtime-web
from
>>>>>> the classpath?
>>>>>>
>>>>>> On 28/11/2019 10:02, Jatin Banger wrote:
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> I checked the log file there is no error.
>>>>>> And I checked the pods internal ports by using rest api.
>>>>>>
>>>>>> # curl <pod-Ip>: 4081
>>>>>> {"errors":["Not found."]}
>>>>>> 4081 is the Ui port
>>>>>>
>>>>>> # curl <pod-Ip>:4081/config
>>>>>> {"refresh-interval":3000,"timezone-name":"Coordinated Universal
>>>>>> Time","timezone-offset":0,"flink-version":"<unknown>","flink-revision":"ceba8af
>>>>>> @ 11.02.2019 @ 22:17:09 CST"}
>>>>>>
>>>>>> # curl <pod-Ip>:4081/jobs
>>>>>> {"jobs":[{"id":"___job_Id_____","status":"RUNNING"}]}
>>>>>>
>>>>>> Which shows the state of the job as running.
>>>>>>
>>>>>> What else can we do ?
>>>>>>
>>>>>> Best regards,
>>>>>> Jatin
>>>>>>
>>>>>> On Thu, Nov 28, 2019 at 1:28 PM vino yang <yanghua1127@gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Hi Jatin,
>>>>>>>
>>>>>>> Flink web UI does not depend on any deployment mode.
>>>>>>>
>>>>>>> You should check if there are error logs in the log file and
the job
>>>>>>> status is running state.
>>>>>>>
>>>>>>> Best,
>>>>>>> Vino
>>>>>>>
>>>>>>> Jatin Banger <bangerjatinrmrvf@gmail.com> 于2019年11月28日周四
下午3:43写道:
>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> It seems there is Web Ui for Flink Session cluster, But for
Flink
>>>>>>>> Job Cluster it is Showing
>>>>>>>>
>>>>>>>> {"errors":["Not found."]}
>>>>>>>>
>>>>>>>> Is it the expected behavior for Flink Job Cluster Mode ?
>>>>>>>>
>>>>>>>> Best Regards,
>>>>>>>> Jatin
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>

Mime
View raw message