flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Becket Qin <becket....@gmail.com>
Subject Re: [DISCUSS] Drop older versions of Kafka Connectors (0.9, 0.10) for Flink 1.10
Date Sun, 15 Sep 2019 23:42:40 GMT
Thanks for bringing this up, Stephan.

I am +1 on dropping support for Kafka 0.8. It is a pretty old version and I
don't think there are many users on that version now.

However, for Kafka 0.9, I think there are still quite some users on that
version. It might be better to keep it a little longer.

Given that dropping connector support is a backwards incompatible change,
technically speaking we need to bump up the major version. I am not sure if
release 1.10 is a good version to remove the code.
Personally I prefer to mark Kafka 0.8 connector as deprecated and remove
the code base in Flink 2.x.

Thanks,

Jiangjie (Becket) Qin


On Wed, Sep 11, 2019 at 4:26 PM Wesley Peng <wesley@thepeng.eu> wrote:

>
>
> on 2019/9/11 16:17, Stephan Ewen wrote:
> > We still maintain connectors for Kafka 0.8 and 0.9 in Flink.
> > I would suggest to drop those with Flink 1.10 and start supporting only
> > Kafka 0.10 onwards.
> >
> > Are there any concerns about this, or still a significant number of
> > users of these versions?
>
> But we still have a large scale of deployment kafka 0.9 in production.
> Do you mean the new coming flink won't support kafka 0.9?
> Though I understand for it, but just sounds sorry. :)
>
> regards.
>

Mime
View raw message