flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xintong Song <tonysong...@gmail.com>
Subject Re: Question in the tutorial
Date Fri, 12 Jul 2019 03:12:03 GMT
Hi Karthik,

I think more information is needed for diagnosing the problem, and I would
suggest you to do the followings:
- Check whether the task managers are configured in the file 'conf/slaves'.
  - If configured, you should see some hosts in the file, each for one task
manager.
- Check whether the task managers are running, by execute the command 'ps
-ef | grep TaskManagerRunner'.
  - If there are task managers running, you should be able to see the
corresponding processes.
- Checks jobmanager / taskmanager logs to find out why the task managers
are not started, or started, but not find by the cluster.
  - You can find the logs in 'log/flink-*-standalonesession-*.log'.
  - If you cannot find the problem from the logs, you can also post them in
this ML for help.

Thank you~

Xintong Song



On Fri, Jul 12, 2019 at 1:57 AM Karthik Guru <karth251998@gmail.com> wrote:

> Hey Flink team,
>
> Novice here. I just about started using Flink. I have a slight issue with
> respect to the following instruction in the tutorial.
>
> https://ci.apache.org/projects/flink/flink-docs-release-1.8/tutorials/local_setup.html
>
> In this, when I try to 'Start a Local Flink Cluster' and then connect to
> local host, I am not getting an update on the task manager. It still shows
> 0 for all the three categories. Could you please help?
>
> Thanks for your time
> Karthik
>

Mime
View raw message