flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xintong Song <tonysong...@gmail.com>
Subject Re: Question in the tutorial
Date Fri, 12 Jul 2019 06:35:59 GMT
It seems to me that your task manager is started and then failed before
registering to the cluster. I think we need the entire log file instead of
the result of tail command. Could you just clear the log dir, start the
cluster again and wait for a little while (1-2 min should be enough), and
post all the new generated files under the log dir here?

Thank you~

Xintong Song



On Fri, Jul 12, 2019 at 2:25 PM Karthik Guru <karth251998@gmail.com> wrote:

> Hello Xintong
>
> Thanks for your reply.
>
> 1)I have attached screenshots of the logs directory (Screenshot 1,2)
>
> 2) In conf/slaves, all I can see is the word 'localhost' written in it. I
> am not sure if that suffices
>
> 3) Screenshot 3 has the result of the command for checking whether task
> managers are running. I am not sure if that is the correct response.
>
> 4) Screenshot 4 has all the logs. I am not too sure how to diagnose the
> problem. I have also attached the localhost 'overview' screenshot.
> (Screenshot 5)
>
> On Fri, Jul 12, 2019 at 8:42 AM Xintong Song <tonysong820@gmail.com>
> wrote:
>
>> Hi Karthik,
>>
>> I think more information is needed for diagnosing the problem, and I
>> would suggest you to do the followings:
>> - Check whether the task managers are configured in the file
>> 'conf/slaves'.
>>   - If configured, you should see some hosts in the file, each for one
>> task manager.
>> - Check whether the task managers are running, by execute the command 'ps
>> -ef | grep TaskManagerRunner'.
>>   - If there are task managers running, you should be able to see the
>> corresponding processes.
>> - Checks jobmanager / taskmanager logs to find out why the task managers
>> are not started, or started, but not find by the cluster.
>>   - You can find the logs in 'log/flink-*-standalonesession-*.log'.
>>   - If you cannot find the problem from the logs, you can also post them
>> in this ML for help.
>>
>> Thank you~
>>
>> Xintong Song
>>
>>
>>
>> On Fri, Jul 12, 2019 at 1:57 AM Karthik Guru <karth251998@gmail.com>
>> wrote:
>>
>>> Hey Flink team,
>>>
>>> Novice here. I just about started using Flink. I have a slight issue
>>> with respect to the following instruction in the tutorial.
>>>
>>> https://ci.apache.org/projects/flink/flink-docs-release-1.8/tutorials/local_setup.html
>>>
>>> In this, when I try to 'Start a Local Flink Cluster' and then connect to
>>> local host, I am not getting an update on the task manager. It still shows
>>> 0 for all the three categories. Could you please help?
>>>
>>> Thanks for your time
>>> Karthik
>>>
>>

Mime
View raw message