flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hequn Cheng <chenghe...@gmail.com>
Subject Re: [SURVEY] Usage of flink-ml and [DISCUSS] Delete flink-ml
Date Mon, 27 May 2019 13:59:34 GMT
Hi Shaoxuan,

Thanks a lot for driving this. +1 to remove the module.

The git log of this module shows that it has been inactive for a long time.
I think it's ok to remove it for now. It would also be good to switch to
the new interface earlier.

Best, Hequn

On Mon, May 27, 2019 at 8:58 PM Becket Qin <becket.qin@gmail.com> wrote:

> +1 for removal. Personally I'd prefer marking it as deprecated and remove
> the module in the next release, just to follow the established procedure.
>
> And +1 on removing the `flink-libraries/flink-ml-uber` as well.
>
> Thanks,
>
> Jiangjie (Becket) Qin
>
> On Mon, May 27, 2019 at 5:07 PM jincheng sun <sunjincheng121@gmail.com>
> wrote:
>
>> +1 for remove it!
>>
>> And we also plan to delete the `flink-libraries/flink-ml-uber`, right?
>>
>> Best,
>> Jincheng
>>
>> Rong Rong <walterddr@gmail.com> 于2019年5月24日周五 上午1:18写道:
>>
>>> +1 for the deletion.
>>>
>>> Also I think it also might be a good idea to update the roadmap for the
>>> plan of removal/development since we've reached the consensus on FLIP-39.
>>>
>>> Thanks,
>>> Rong
>>>
>>>
>>> On Wed, May 22, 2019 at 8:26 AM Shaoxuan Wang <wshaoxuan@gmail.com>
>>> wrote:
>>>
>>>> Hi Chesnay,
>>>> Yes, you are right. There is not any active commit planned for the
>>>> legacy Flink-ml package. It does not matter delete it now or later. I will
>>>> open a PR and remove it.
>>>>
>>>> Shaoxuan
>>>>
>>>> On Wed, May 22, 2019 at 7:05 PM Chesnay Schepler <chesnay@apache.org>
>>>> wrote:
>>>>
>>>>> I believe we can remove it regardless since users could just use the
>>>>> 1.8
>>>>> version against future releases.
>>>>>
>>>>> Generally speaking, any library/connector that is no longer actively
>>>>> developed can be removed from the project as existing users can always
>>>>> rely on previous versions, which should continue to work by virtue of
>>>>> working against @Stable APIs.
>>>>>
>>>>> On 22/05/2019 12:08, Shaoxuan Wang wrote:
>>>>> > Hi Flink community,
>>>>> >
>>>>> > We plan to delete/deprecate the legacy flink-libraries/flink-ml
>>>>> package in
>>>>> > Flink1.9, and replace it with the new flink-ml interface proposed
in
>>>>> FLIP39
>>>>> > (FLINK-12470).
>>>>> > Before we remove this package, I want to reach out to you and ask
if
>>>>> there
>>>>> > is any active project still uses this package. Please respond to
this
>>>>> > thread and outline how you use flink-libraries/flink-ml.
>>>>> > Depending on the replies of activity and adoption
>>>>> > of flink-libraries/flink-ml, we will decide to either delete this
>>>>> package
>>>>> > in Flink1.9 or deprecate it for now & remove it in the next
release
>>>>> after
>>>>> > 1.9.
>>>>> >
>>>>> > Thanks for your attention and help!
>>>>> >
>>>>> > Regards,
>>>>> > Shaoxuan
>>>>> >
>>>>>
>>>>>

Mime
View raw message