flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vino yang <yanghua1...@gmail.com>
Subject Re: Checkpointing not happening in Standalone HA mode
Date Thu, 26 Jul 2018 06:34:41 GMT
Hi Vinay:

Did you call specific config API refer to this documentation[1];

Can you share your job program and JM Log? Or the JM log contains the log
message like this pattern "Triggering checkpoint {} @ {} for job {}."?

[1]:
https://ci.apache.org/projects/flink/flink-docs-release-1.5/dev/stream/state/checkpointing.html#enabling-and-configuring-checkpointing

Thanks, vino.

2018-07-25 19:43 GMT+08:00 Chesnay Schepler <chesnay@apache.org>:

> Can you provide us with the job code?
>
> I assume that checkpointing runs properly if you submit the same job to a
> normal cluster?
>
>
> On 25.07.2018 13:15, Vinay Patil wrote:
>
> No error in the logs. That is why I am not able to understand why
> checkpoints are not getting triggered.
>
> Regards,
> Vinay Patil
>
>
> On Wed, Jul 25, 2018 at 4:44 PM Vinay Patil <vinay18.patil@gmail.com>
> wrote:
>
>> Hi Chesnay,
>>
>> No error in the logs. That is why I am not able to understand why
>> checkpoints are getting triggered.
>>
>> Regards,
>> Vinay Patil
>>
>>
>> On Wed, Jul 25, 2018 at 4:36 PM Chesnay Schepler <chesnay@apache.org>
>> wrote:
>>
>>> Please check the job- and taskmanager logs for anything suspicious.
>>>
>>> On 25.07.2018 12:33, Vinay Patil wrote:
>>>
>>> Hi,
>>>
>>> I am starting the cluster using bootstrap application where in I am
>>> calling Job Manager and Task Manager main class to form the cluster. The HA
>>> cluster is formed correctly and I am able to submit jobs to this cluster
>>> using RemoteExecutionEnvironment but when I enable checkpointing in code I
>>> do not see any checkpoints triggered on Flink UI.
>>>
>>> Am I missing any configurations to be set for the
>>> RemoteExecutionEnvironment for checkpointing to work.
>>>
>>>
>>> Regards,
>>> Vinay Patil
>>>
>>>
>>>
>

Mime
View raw message