flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 김동원 <eastcirc...@gmail.com>
Subject Re: JobManager not receiving resource offers from Mesos
Date Wed, 03 Jan 2018 06:12:19 GMT
Oops, I forgot to include files in the previous mail.




> 2018. 1. 3. 오후 3:10, 김동원 <eastcirclek@gmail.com> 작성:
> 
> Hi,
> 
> I try to launch a Flink cluster on top of dc/os but TaskManagers are not launched at
all.
> 
> What I do to launch a Flink cluster is as follows:
> - Click "flink" from "Catalog" on the left panel of dc/os GUI.
> - Click "Run service" without any modification on configuration for the purpose of testing
(Figure 1).
> 
> Until now, everything seems okay as shown in Figure 2.
> However, Figure 3 shows that TaskManager has never been launched.
> 
> So I take a look at JobManager log (see the attached "log.txt" for full log).
> LaunchCoordinator is spitting the same log messages while staying in "GetheringOffers"
state as follows:
> INFO  org.apache.flink.mesos.scheduler.LaunchCoordinator            - Processing 1 task(s)
against 0 new offer(s) plus outstanding off$
> DEBUG com.netflix.fenzo.TaskScheduler                               - Found 0 VMs with
non-zero offers to assign from
> INFO  org.apache.flink.mesos.scheduler.LaunchCoordinator            - Resources considered:
(note: expired offers not deducted from be$
> DEBUG org.apache.flink.mesos.scheduler.LaunchCoordinator            - SchedulingResult{resultMap={},
failures={}, leasesAdded=0, lease$
> INFO  org.apache.flink.mesos.scheduler.LaunchCoordinator            - Waiting for more
offers; 1 task(s) are not yet launched.
> (FYI, ConnectionMonitor is in its "ConnectedState" as you can see in the full log file.)
> 
> Can anyone point out what's going wrong on my dc/os installation?
> Thanks you for attention. I'm really looking forward to running Flink clusters on dc/os
:-)
> 
> p.s. I tested whether dc/os is working correctly by using the following scripts and it
works.
> {
>      "id": "simple-gpu-test",
>      "acceptedResourceRoles":["slave_public", "*"],
>      "cmd": "while [ true ] ; do nvidia-smi; sleep 5; done",
>      "cpus": 1,
>      "mem": 128,
>      "disk": 0,
>      "gpus": 1,
>      "instances": 8
> }
> 
> 


Mime
View raw message