flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aljoscha Krettek <aljos...@apache.org>
Subject Re: Using latency markers
Date Fri, 11 Aug 2017 13:44:29 GMT
Ok, I can also confirm that it doesn't work. I'll look into this and will let you know what
I find.

Best,
Aljoscha

> On 11. Aug 2017, at 14:57, Kien Truong <duckientruong@gmail.com> wrote:
> 
> Yes, we also tried changing the tracking interval to no avail, still no latency metric.
> Kien
> 
> On 8/11/2017 7:26 PM, Gyula Fóra wrote:
>> Yes, they are enabled by default I think.
>> 
>> Gyula
>> 
>> 
>> On Fri, Aug 11, 2017, 14:14 Aljoscha Krettek <aljoscha@apache.org <mailto:aljoscha@apache.org>>
wrote:
>> It seems you have to enable latency tracking via ExecutionConfig.setLatencyTrackingInterval(...).
This will make the sources emit latency tokens, which then in turn update the latency metric:
https://ci.apache.org/projects/flink/flink-docs-release-1.3/monitoring/metrics.html#latency-tracking
<https://ci.apache.org/projects/flink/flink-docs-release-1.3/monitoring/metrics.html#latency-tracking>.
>> 
>> Did you enable that?
>> 
>> Best,
>> Aljoscha
>> 
>> 
>>> On 10. Aug 2017, at 18:36, Kien Truong <duckientruong@gmail.com <mailto:duckientruong@gmail.com>>
wrote:
>>> 
>>> Hi,
>>> 
>>> I just want to say we're having the same issues.
>>> 
>>> There's no metric for latency when we attempted to export the metrics through
graphite either.
>>> 
>>> 
>>> Regards,
>>> 
>>> Kien
>>> 
>>> 
>>> On 8/10/2017 7:36 PM, Aljoscha Krettek wrote:
>>>> Hi,
>>>> 
>>>> I must admit that I've never used this but I'll try and look into it.
>>>> 
>>>> Best,
>>>> Aljoscha
>>>> 
>>>>> On 10. Aug 2017, at 11:10, Gyula Fóra <gyula.fora@gmail.com <mailto:gyula.fora@gmail.com>>
wrote:
>>>>> 
>>>>> Hi all!
>>>>> 
>>>>> Does anyone have a working example of using the latency markers to test
for the topology latency?
>>>>> We are using Flink 1.3.2 and it seems like however we tune it, whatever
job we use all we get is NaN in the metrics. Maybe we are completely missing something...
>>>>> 
>>>>> Thanks!
>>>>> Gyula
>>> 
>> 
> 


Mime
View raw message