flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chesnay Schepler <ches...@apache.org>
Subject Re: Flink Kinesis connector in 1.3.0
Date Wed, 14 Jun 2017 06:08:00 GMT
Did you activate the "include-kinesis" maven profile when building?

On 13.06.2017 22:49, Foster, Craig wrote:
>
> Oh, sorry. I’m not using distributed libraries but trying to build 
> from source. So, using Maven 3.2.2 and building the connector doesn’t 
> give me a jar for some reason.
>
> *From: *Chesnay Schepler <chesnay@apache.org>
> *Date: *Tuesday, June 13, 2017 at 1:44 PM
> *To: *"Foster, Craig" <foscraig@amazon.com>, "user@flink.apache.org" 
> <user@flink.apache.org>, Robert Metzger <rmetzger@apache.org>
> *Subject: *Re: Flink Kinesis connector in 1.3.0
>
> Here's the relevant JIRA: 
> https://issues.apache.org/jira/browse/FLINK-6812 
> <https://issues.apache.org/jira/browse/FLINK-6812>
>
> Apologies if I was unclear, i meant that you could use the 
> 1.3-SNAPSHOT version of the kinesis connector, as it is compatible 
> with 1.3.0.
> Alternatively you can take the 1.3.0 sources and build the connector 
> manually.
>
> As far as I'm aware there is no plan to retroactively release a 1.3.0 
> artifact.
>
>
> I'm not aware of the missing httpclient dependency, pulling in Robert 
> who may know something about it.
>
>
> On 13.06.2017 21:00, Foster, Craig wrote:
>
>     So, in addition to the question below, can we be more clear on if
>     there is a patch/fix/JIRA available since I have to use 1.3.0?
>
>     *From: *"Foster, Craig" <foscraig@amazon.com>
>     <mailto:foscraig@amazon.com>
>     *Date: *Tuesday, June 13, 2017 at 9:27 AM
>     *To: *Chesnay Schepler <chesnay@apache.org>
>     <mailto:chesnay@apache.org>, "user@flink.apache.org"
>     <mailto:user@flink.apache.org> <user@flink.apache.org>
>     <mailto:user@flink.apache.org>
>     *Subject: *Re: Flink Kinesis connector in 1.3.0
>
>     Thanks! Does this also explain why commons HttpClient is not
>     included in flink-dist-*?
>
>     *From: *Chesnay Schepler <chesnay@apache.org>
>     <mailto:chesnay@apache.org>
>     *Date: *Tuesday, June 13, 2017 at 8:53 AM
>     *To: *"user@flink.apache.org" <mailto:user@flink.apache.org>
>     <user@flink.apache.org> <mailto:user@flink.apache.org>
>     *Subject: *Re: Flink Kinesis connector in 1.3.0
>
>     Something went wrong during the release process which prevented
>     the 1.3.0 kinesis artifact from being released.
>
>     This will be fixed for 1.3.1, in the mean time you can use
>     1.3.0-SNAPSHOT instead.
>
>     On 13.06.2017 17:48, Foster, Craig wrote:
>
>         Hi:
>
>         I’m trying to build an application that uses the Flink Kinesis
>         Connector in 1.3.0. However, I don’t see that resolving
>         anymore. It resolved with 1.2.x but doesn’t with 1.3.0. Is
>         there something I need to now do differently than described here?
>
>         https://ci.apache.org/projects/flink/flink-docs-release-1.3/dev/connectors/kinesis.html
>
>         Thanks,
>
>         Craig
>


Mime
View raw message