flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timo Walther <twal...@apache.org>
Subject Re: shaded version of legacy kafka connectors
Date Tue, 21 Mar 2017 08:37:58 GMT
Hi Gwenhael,

I will loop in Gordon becaue he is more familar with the Kafka 
connectors. Have you experiences with two versions in the same project?


Am 20/03/17 um 15:57 schrieb Gwenhael Pasquiers:
>
> Hi,
>
> Before doing it myself I thought it would be better to ask.
>
> We need to consume from kafka 0.8 and produce to kafka 0.10 in a flink 
> app.
>
> I guess there will be classes and package names conflicts for a lot of 
> dependencies of both connectors.
>
> The obvious solution it to make a “shaded” version of the kafka 0.8 
> connector so that it can coexist with the 0.10 version.
>
> Does it already exists ?
>


Mime
View raw message