flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Flavio Pompermaier <pomperma...@okkam.it>
Subject Re: Missing test dependency in Eclipse with Flink 1.2.0
Date Tue, 14 Feb 2017 17:18:33 GMT
Great! Thanks a lot

On 14 Feb 2017 6:07 p.m., "Nico Kruber" <nico@data-artisans.com> wrote:

> I did some digging and this is actually documented in FLINK-4813 [1].
>
> To work around this issue, add the following plugin to your build plugins:
>
> <!--
>   https://issues.apache.org/jira/browse/DIRSHARED-134
>   Required to pull the Mini-KDC transitive dependency
> -->
> <plugin>
>         <groupId>org.apache.felix</groupId>
>         <artifactId>maven-bundle-plugin</artifactId>
>         <version>3.0.1</version>
>         <inherited>true</inherited>
>         <extensions>true</extensions>
> </plugin>
>
>
> Nico
>
> [1] https://issues.apache.org/jira/browse/FLINK-4813
>
> On Tuesday, 14 February 2017 17:45:12 CET Flavio Pompermaier wrote:
> > Hi Nico,
> > thanks for the response. The problem is that I don't use the quickstart
> > example.
> > I have a working set of jobs (in Flink 1.1.4) with some unit tests.
> > In the unit tests I use the following dependency that causes the problem:
> >
> >        <dependency>
> >             <groupId>org.apache.flink</groupId>
> >             <artifactId>flink-test-utils_2.10</artifactId>
> >             <version>1.2.0</version>
> >             <type>test-jar</type>
> >             <scope>test</scope>
> >         </dependency>
> >
> > Best,
> > Flavio
> >
> > On Tue, Feb 14, 2017 at 2:51 PM, Nico Kruber <nico@data-artisans.com>
> wrote:
> > > You do not require a plugin, but most probably this dependency was not
> > > fetched
> > > by Eclipse. Please try a "mvn clean package" in your project and see
> > > whether
> > > this helps Eclipse.
> > >
> > > Also, you may create a clean test project with
> > >
> > > mvn archetype:generate                               \
> > >
> > >       -DarchetypeGroupId=org.apache.flink              \
> > >       -DarchetypeArtifactId=flink-quickstart-java      \
> > >       -DarchetypeVersion=1.2.0
> > >
> > > for which I could not find any dependency issues using Eclipse.
> > >
> > > Regards,
> > > Nico
> > >
> > > On Tuesday, 14 February 2017 14:17:10 CET Flavio Pompermaier wrote:
> > > > Hi to all,
> > > > I've tried to migrate to Flink 1.2.0 and now my Eclipse projects says
> > >
> > > that
> > >
> > > > they can't find *apacheds-jdbm1* that has packaging bundle. Should I
> > > > install some plugin?
> > > >
> > > > Best,
> > > > Flavio
>
>

Mime
View raw message